xserver_xorg-server: enable libunwind for MIPS with 32-bit pointers
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Sun, 15 Feb 2015 18:10:59 +0000 (18:10 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 19 Feb 2015 21:29:59 +0000 (22:29 +0100)
libunwind support was broken for MIPS variants with 32-bit pointers so
we disabled it:

  http://lists.busybox.net/pipermail/buildroot/2014-December/114404.html

But now we have a patch to fix that problem so we can enable it again.

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/x11r7/xserver_xorg-server/xserver_xorg-server.mk

index bde2b9533ec78b2cd2baeffc6365baacca4eed02..35bdd4407fdc39d3ca154c03cf65a642ee44f6e4 100644 (file)
@@ -145,9 +145,7 @@ ifeq ($(BR2_PACKAGE_FREETYPE),y)
 XSERVER_XORG_SERVER_DEPENDENCIES += freetype
 endif
 
-# libunwind support is broken on all MIPS variants with 32-bit pointers
-# https://bugs.freedesktop.org/show_bug.cgi?id=79939
-ifeq ($(BR2_PACKAGE_LIBUNWIND)-$(BR2_MIPS_OABI32)-$(BR2_MIPS_NABI32),y--)
+ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
 XSERVER_XORG_SERVER_DEPENDENCIES += libunwind
 XSERVER_XORG_SERVER_CONF_OPTS += --enable-libunwind
 else