package/x11r7/xlib_libXfont2: work around gcc bug 85180
authorGiulio Benetti <giulio.benetti@micronovasrl.com>
Fri, 12 Jul 2019 09:04:07 +0000 (11:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 14 Jul 2019 13:05:47 +0000 (15:05 +0200)
On Microblaze, with gcc versions < 8.x the build of xlib_libXfont2
hangs due to gcc bug 85180:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=85180.

The bug shows up when building xlib_libXfont2 with optimization but
not when building with -O0. To work around this, if
BR2_TOOLCHAIN_HAS_GCC_BUG_85180=y we force using -O0.

Fixes:

  http://autobuild.buildroot.net/results/21099d27c03948daaca2d1c149eeba084427e3af/

Signed-off-by: Giulio Benetti <giulio.benetti@micronovasrl.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/x11r7/xlib_libXfont2/xlib_libXfont2.mk

index ba2c7540cb0cd5cb3211986811212a41d42c7737..65adf665bdb80b78070b553098f372db94f19944 100644 (file)
@@ -27,5 +27,13 @@ HOST_XLIB_LIBXFONT2_DEPENDENCIES = \
 XLIB_LIBXFONT2_CONF_OPTS = --disable-devel-docs
 HOST_XLIB_LIBXFONT2_CONF_OPTS = --disable-devel-docs
 
+XLIB_LIBXFONT2_CFLAGS = $(TARGET_CFLAGS)
+
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_85180),y)
+XLIB_LIBXFONT2_CFLAGS += -O0
+endif
+
+XLIB_LIBXFONT2_CONF_ENV = CFLAGS="$(XLIB_LIBXFONT2_CFLAGS)"
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))