package/vlc: Add libsidplay2 as optional dependency
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 18 Jun 2015 20:19:41 +0000 (22:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 28 Jun 2015 20:56:14 +0000 (22:56 +0200)
vlc has a sid plugin:

$ output/host/usr/bin/i586-buildroot-linux-uclibc-readelf -a
  output/target/usr/lib/vlc/plugins/demux/libsid_plugin.so |
  grep NEEDED | grep sid
 0x00000001 (NEEDED)     Shared library: [libsidplay2.so.1]
 0x00000001 (NEEDED)     Shared library: [libresid-builder.so.0]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/vlc/vlc.mk

index bc2966eed0a733da7ae3789f17630df374db2864..4ef69aa44af460f656ceb4cb05ec24505e942249 100644 (file)
@@ -206,6 +206,13 @@ else
 VLC_CONF_OPTS += --disable-svg --disable-svgdec
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSIDPLAY2),y)
+VLC_CONF_OPTS += --enable-sid
+VLC_DEPENDENCIES += libsidplay2
+else
+VLC_CONF_OPTS += --disable-sid
+endif
+
 ifeq ($(BR2_PACKAGE_LIBTHEORA),y)
 VLC_CONF_OPTS += --enable-theora
 VLC_DEPENDENCIES += libtheora