package/cage: new package
authorAdrian Perez de Castro <aperez@igalia.com>
Sun, 10 Nov 2019 20:06:38 +0000 (22:06 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 26 Apr 2020 13:05:17 +0000 (15:05 +0200)
Cage is a "kiosk" Wayland compositor, which shows a single maximized
application at a time and limits user interaction to that application.

https://www.hjdskes.nl/projects/cage/

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/cage/Config.in [new file with mode: 0644]
package/cage/cage.hash [new file with mode: 0644]
package/cage/cage.mk [new file with mode: 0644]

index d6557f1143ed6329e4aac0e351501deae55249d2..34e19b451ebde3ff6b3025525d40fbe9c763e940 100644 (file)
@@ -95,6 +95,7 @@ F:    package/jack1/
 N:     Adrian Perez de Castro <aperez@igalia.com>
 F:     package/brotli/
 F:     package/bubblewrap/
+F:     package/cage/
 F:     package/cog/
 F:     package/libepoxy/
 F:     package/libwpe/
index 6c55c5bc429011b93681dde993ed3b857c88d206..bf02870ea214e50a9e5229c9bfac4637e5a647aa 100644 (file)
@@ -278,6 +278,7 @@ endmenu
 menu "Graphic libraries and applications (graphic/text)"
 
 comment "Graphic applications"
+       source "package/cage/Config.in"
        source "package/cog/Config.in"
        source "package/fswebcam/Config.in"
        source "package/ghostscript/Config.in"
diff --git a/package/cage/Config.in b/package/cage/Config.in
new file mode 100644 (file)
index 0000000..c809775
--- /dev/null
@@ -0,0 +1,24 @@
+comment "cage needs udev, mesa3d w/ EGL and GLES support"
+       depends on !BR2_PACKAGE_MESA3D_OPENGL_EGL || \
+               !BR2_PACKAGE_MESA3D_OPENGL_ES || \
+               !BR2_PACKAGE_HAS_UDEV
+
+comment "cage needs a toolchain w/ threads, locale, dynamic library"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS || \
+               !BR2_ENABLE_LOCALE || \
+               BR2_STATIC_LIBS
+
+config BR2_PACKAGE_CAGE
+       bool "cage"
+       depends on !BR2_STATIC_LIBS # wlroots
+       depends on BR2_TOOLCHAIN_HAS_THREADS # wlroots
+       depends on BR2_ENABLE_LOCALE # wlroots
+       depends on BR2_PACKAGE_HAS_UDEV # wlroots
+       depends on BR2_PACKAGE_MESA3D_OPENGL_EGL # wlroots
+       depends on BR2_PACKAGE_MESA3D_OPENGL_ES # wlroots
+       select BR2_PACKAGE_WLROOTS
+       help
+         Kiosk compositor for Wayland, which displays a single
+         maximized application at a time.
+
+         https://www.hjdskes.nl/projects/cage/
diff --git a/package/cage/cage.hash b/package/cage/cage.hash
new file mode 100644 (file)
index 0000000..49b84f9
--- /dev/null
@@ -0,0 +1,5 @@
+# Generated locally, after checking https://github.com/Hjdskes/cage/releases/download/v0.1.1/cage-0.1.1.tar.gz.sig
+sha256 63efbe96cf307381f2bedf9b80153343e255970a70d612515da7dc325dd49478  cage-0.1.1.tar.gz
+
+# Hashes for license files:
+sha256 1fd28695090b961ed2846627365489228d84f784bff60a90e933febcedaeb65d  LICENSE
diff --git a/package/cage/cage.mk b/package/cage/cage.mk
new file mode 100644 (file)
index 0000000..6a9c067
--- /dev/null
@@ -0,0 +1,18 @@
+################################################################################
+#
+# cage
+#
+################################################################################
+
+CAGE_VERSION = 0.1.1
+CAGE_SITE = $(call github,Hjdskes,cage,v$(CAGE_VERSION))
+CAGE_LICENSE = MIT
+CAGE_DEPENDENCIES = host-pkgconf wlroots
+
+ifeq ($(BR2_PACKAGE_XORG7),y)
+CAGE_CONF_OPTS = -Dxwayland=true
+else
+CAGE_CONF_OPTS = -Dxwayland=false
+endif
+
+$(eval $(meson-package))