When both busybox and coreutils and/or util-linux are selected,
authorEric Andersen <andersen@codepoet.org>
Mon, 27 Dec 2004 21:49:53 +0000 (21:49 -0000)
committerEric Andersen <andersen@codepoet.org>
Mon, 27 Dec 2004 21:49:53 +0000 (21:49 -0000)
make certain that it is coreutils and/or util-linux that actually
gets their utilities installed.
 -Erik

package/coreutils/coreutils.mk
package/util-linux/util-linux.mk

index caad648a8fcab7e1fb356fec466b931db91a30bf..df07a08850b02803d0a7746114d58468e7d53b9c 100644 (file)
@@ -73,7 +73,13 @@ $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY): $(COREUTILS_DIR)/$(COREUTILS_BINARY)
        rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
                $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
 
+#If both coreutils and busybox are selected, make certain coreutils
+#wins the fight over who gets to have their utils actually installed
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+coreutils: uclibc busybox $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY)
+else
 coreutils: uclibc $(TARGET_DIR)/$(COREUTILS_TARGET_BINARY)
+endif
 
 coreutils-clean:
        $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(COREUTILS_DIR) uninstall
index fd0b7240f1a5529483538b506f03366d6da1e35c..8cdce96906a0a791169dfd58baafedb57b869ede 100644 (file)
@@ -60,7 +60,14 @@ $(UTIL-LINUX_TARGET_BINARY): $(UTIL-LINUX_BINARY)
        rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/share/info \
                $(TARGET_DIR)/usr/share/man $(TARGET_DIR)/usr/share/doc
 
+#If both util-linux and busybox are selected, make certain util-linux
+#wins the fight over who gets to have their utils actually installed
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+util-linux: uclibc busybox $(UTIL-LINUX_TARGET_BINARY)
+else
 util-linux: uclibc $(UTIL-LINUX_TARGET_BINARY)
+endif
+
 
 util-linux-source: $(DL_DIR)/$(UTIL-LINUX_SOURCE)