Patrick Doyle writes:
authorMike Frysinger <vapier@gentoo.org>
Mon, 11 Jul 2005 21:53:23 +0000 (21:53 -0000)
committerMike Frysinger <vapier@gentoo.org>
Mon, 11 Jul 2005 21:53:23 +0000 (21:53 -0000)
target/device/Soekris/net4521/linux.mk is missing an endif for
the first if statement

target/device/Soekris/Makefile.in needs to set TARGETS before
including linux.mk since the file checks the TARGETS variables

target/device/Soekris/Makefile.in
target/device/Soekris/net4521/linux.mk

index 55efdd38eaf4282351b2f07f29e4451d725baad6..93b5f101855572e39256a22fa70c74ec2145e199 100644 (file)
@@ -4,9 +4,8 @@ UCLIBC_CONFIG_FILE:=target/device/Soekris/net4521/uClibc.config
 BR2_PACKAGE_BUSYBOX_CONFIG:=target/device/Soekris/net4521/busybox.config
 
 ifeq ($(strip $(BR2_PACKAGE_LINUX)),y)
-include target/device/Soekris/net4521/linux.mk
 TARGETS+=linux
+include target/device/Soekris/net4521/linux.mk
 endif
 
 endif
-
index 6c04e422259f448ca87457bff5db405f9bb1547c..7a552a39b59516a68e72072ce94d27faafb83c2d 100644 (file)
@@ -122,3 +122,4 @@ linuxclean: clean
 linux-dirclean:
        rm -rf $(LINUX_DIR)
 
+endif