webkitgtk: Allow toggling WebDriver support
authorAdrian Perez de Castro <aperez@igalia.com>
Wed, 13 Sep 2017 16:51:21 +0000 (19:51 +0300)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 24 Sep 2017 12:35:31 +0000 (14:35 +0200)
Version 2.18.x includes support for remotely controlling WebKitGTK+
based browsers using the standard WebDriver API. Typically this is used
by Web developers, and in most cases it will be desirable to disable it
from builds.

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/webkitgtk/Config.in
package/webkitgtk/webkitgtk.mk

index e0b5947faa9ae4f81b7171b373008d2dcf5c3bc1..65154db3fa920375eff1601468085b5ea4af836b 100644 (file)
@@ -82,4 +82,10 @@ config BR2_PACKAGE_WEBKITGTK_MULTIMEDIA
          This option pulls in all of the required dependencies
          to enable multimedia (video/audio) support.
 
+config BR2_PACKAGE_WEBKITGTK_WEBDRIVER
+       bool "WebDriver support"
+       help
+         Enable support for WebDriver. This will build and install the
+         WebKitWebDriver program in the target.
+
 endif
index bac1e715a5db5900813a6ab4074846cbad7214f2..7cdf28cd6f3cd44dd0720d743c771721fce3cf83 100644 (file)
@@ -49,6 +49,12 @@ WEBKITGTK_CONF_OPTS += \
        -DENABLE_MEDIA_STREAM=OFF
 endif
 
+ifeq ($(BR2_PACKAGE_WEBKITGTK_WEBDRIVER),y)
+WEBKITGTK_CONF_OPTS += -DENABLE_WEBDRIVER=ON
+else
+WEBKITGTK_CONF_OPTS += -DENABLE_WEBDRIVER=OFF
+endif
+
 # Only one target platform can be built, assume X11 > Wayland
 
 # GTK3-X11 target gives OpenGL from newer libgtk3 versions