matchbox: apply libtool patch to matchbox-desktop
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2010 13:26:02 +0000 (14:26 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 Feb 2010 19:34:35 +0000 (20:34 +0100)
matchbox-desktop fails to build because it tries to read
/usr/lib/libxcb.la, which doesn't exist on a very basic system with no
development files instead. The buildroot-libtool.patch must therefore
be applied.

Unfortunately, matchbox doesn't yet use the autotools infrastructure,
so we have to manually apply the patch.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/matchbox/matchbox.mk

index 06e94cda174751399a60621ce1554dc60343db8e..8665d417babcdd4701911272ac11ecc42e7898ff 100644 (file)
@@ -141,6 +141,7 @@ $(MATCHBOX_PL_DIR)/.unpacked: $(DL_DIR)/$(MATCHBOX_PL_SOURCE)
 $(MATCHBOX_DP_DIR)/.unpacked: $(DL_DIR)/$(MATCHBOX_DP_SOURCE)
        $(MATCHBOX_CAT) $(DL_DIR)/$(MATCHBOX_DP_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
        $(SED) 's:mbfolder\.png:mbtasks\.png:g' $(MATCHBOX_DP_DIR)/modules/tasks.c
+       toolchain/patch-kernel.sh $(MATCHBOX_DP_DIR) package/ buildroot-libtool.patch
        touch $(MATCHBOX_DP_DIR)/.unpacked
 
 $(MATCHBOX_FK_DIR)/.unpacked: $(DL_DIR)/$(MATCHBOX_FK_SOURCE)