package/janet: add -std=c99 to CFLAGS
authorBartosz Bilas <b.bilas@grinn-global.com>
Thu, 4 Mar 2021 17:54:28 +0000 (18:54 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 5 Mar 2021 22:15:17 +0000 (23:15 +0100)
As upstream says Janet should be compiled with -std=c99
so pass this in order to fix the failures below.

Fixes:
 http://autobuild.buildroot.net/results/192/1922ec115b9dc9e879760a6868969d9677093510/build-end.log
 ...
 http://autobuild.buildroot.net/results/355/355e0992338a8d132050517f83a3884606b00529/build-end.log

Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/janet/janet.mk

index 7243d60c011ddb4929e934a8554de8e1a8175ffd..ea042221d8ce34ba778db71b57fb593b6dbb2257 100644 (file)
@@ -8,8 +8,8 @@ JANET_VERSION = 1.15.0
 JANET_SITE = $(call github,janet-lang,janet,v$(JANET_VERSION))
 JANET_LICENSE = MIT
 JANET_LICENSE_FILES = LICENSE
-
 JANET_INSTALL_STAGING = YES
+JANET_CFLAGS = $(TARGET_CFLAGS) -std=c99
 
 ifeq ($(BR2_STATIC_LIBS),y)
 JANET_CONF_OPTS += -Ddynamic_modules=false