target/: remove the COPYTO mess
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 2 Mar 2010 22:10:49 +0000 (23:10 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 9 Apr 2010 09:04:33 +0000 (11:04 +0200)
There's no need to provide options to copy the filesystem image after
the build. Just use 'cp' outside of Buildroot.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
target/cpio/Config.in
target/cpio/cpioroot.mk
target/ext2/Config.in
target/ext2/ext2root.mk
target/jffs2/Config.in
target/jffs2/jffs2root.mk
target/tar/Config.in
target/tar/tarroot.mk
target/ubifs/Config.in
target/ubifs/ubifsroot.mk

index 4ee1037d4ac86edf74e7401d26d0a0124cc95766..02fd00d3423604d9800e765c9a156bbf3f3ed73f 100644 (file)
@@ -38,12 +38,3 @@ config BR2_TARGET_ROOTFS_CPIO_LZMA
 
 endchoice
 
-config BR2_TARGET_ROOTFS_CPIO_COPYTO
-       string "also copy the image to..."
-       depends on BR2_TARGET_ROOTFS_CPIO
-       default ""
-       help
-         Copies the resulting image to a secondary location
-         like a tftp server's root directory.
-       
-         Example: $(IMAGE)-$(DATE).cpio$(CPIO_ROOTFS_COMPRESSOR_EXT)
index 021847ffd5703bceb9c889341c74dea41f942b42..0984b725f0bcd768878b5bfb6e317d760b76d437 100644 (file)
@@ -29,8 +29,6 @@ else
 CPIO_TARGET := $(CPIO_BASE)
 endif
 
-ROOTFS_CPIO_COPYTO:=$(call qstrip,$(BR2_TARGET_ROOTFS_CPIO_COPYTO))
-
 cpioroot-init:
        rm -f $(TARGET_DIR)/init
        ln -s sbin/init $(TARGET_DIR)/init
@@ -52,18 +50,10 @@ endif
        chmod a+x $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
        $(HOST_DIR)/usr/bin/fakeroot -- $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
        -@rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(CPIO_BASE))
-ifeq ($(CPIO_ROOTFS_COMPRESSOR),)
-ifneq ($(ROOTFS_CPIO_COPYTO),)
-       $(Q)cp -f $(CPIO_BASE) $(ROOTFS_CPIO_COPYTO)
-endif
-endif
 
 ifneq ($(CPIO_ROOTFS_COMPRESSOR),)
 $(CPIO_BASE).$(CPIO_ROOTFS_COMPRESSOR_EXT): $(CPIO_ROOTFS_COMPRESSOR_PREREQ) $(CPIO_BASE)
        $(CPIO_ROOTFS_COMPRESSOR) $(CPIO_BASE) > $(CPIO_TARGET)
-ifneq ($(ROOTFS_CPIO_COPYTO),)
-       $(Q)cp -f $(CPIO_BASE).$(CPIO_ROOTFS_COMPRESSOR_EXT) $(ROOTFS_CPIO_COPYTO).$(CPIO_ROOTFS_COMPRESSOR_EXT)
-endif
 endif
 
 #############################################################
index 1b1dc8a21597a39d8a756865ab7d467045ec48a9..0047309040f625a552de8009f1c21e7ee171b08f 100644 (file)
@@ -64,11 +64,3 @@ config BR2_TARGET_ROOTFS_EXT2_LZMA
 
 endchoice
 
-config BR2_TARGET_ROOTFS_EXT2_COPYTO
-       string "also copy the image to..."
-       depends on BR2_TARGET_ROOTFS_EXT2
-       default ""
-       help
-         Copies the resulting image to a secondary location
-         like a tftp server's root directory.
-
index 6c8e02a9ba555e073be710b5e00a0714d0a5912d..145b182fe0f3fcf822bca0460c48d18417e7f477 100644 (file)
@@ -82,13 +82,7 @@ $(EXT2_BASE).$(EXT2_ROOTFS_COMPRESSOR_EXT): $(EXT2_ROOTFS_COMPRESSOR_PREREQ) $(E
        $(EXT2_ROOTFS_COMPRESSOR) $(EXT2_BASE) > $(EXT2_TARGET)
 endif
 
-EXT2_COPYTO := $(call qstrip,$(BR2_TARGET_ROOTFS_EXT2_COPYTO))
-
 ext2root: $(EXT2_TARGET)
-       @ls -l $(EXT2_TARGET)
-ifneq ($(EXT2_COPYTO),)
-       @cp -f $(EXT2_TARGET) $(EXT2_COPYTO)
-endif
 
 #############################################################
 #
index bf4ac607985d9869d16806477b925fa34df5f752..a216a27f04ea591716304ffd847cbd115fe7bfbf 100644 (file)
@@ -118,10 +118,4 @@ config BR2_TARGET_ROOTFS_JFFS2_OUTPUT
        string "Output File"
        default "$(IMAGE).jffs2"
 
-config BR2_TARGET_ROOTFS_JFFS2_COPYTO
-       string "also copy the image to..."
-       default ""
-       help
-         Copies the resulting image to a secondary location.
-
 endif
index 30ac86ddfe7efe97dffdd595e28f6909ce0fa8cd..eea0e3a490943b868806fe6f5eff190195859f13 100644 (file)
@@ -74,12 +74,7 @@ ifeq ($(BR2_JFFS2_TARGET_SREC),y)
        @ls -l $(JFFS2_TARGET).srec
 endif
 
-JFFS2_COPYTO := $(call qstrip,$(BR2_TARGET_ROOTFS_JFFS2_COPYTO))
-
 jffs2root: $(JFFS2_TARGET)
-ifneq ($(JFFS2_COPYTO),)
-       @cp -f $(JFFS2_TARGET) $(JFFS2_COPYTO)
-endif
 
 #############################################################
 #
index ae024094ac912de48123ce3000e0af1e553e00a7..0adca795f01684dbabacdee4682765aa81d340ed 100644 (file)
@@ -45,14 +45,3 @@ config BR2_TARGET_ROOTFS_TAR_OPTIONS
        help
          Any other flags you want to pass to tar
          Refer to tar --help for details
-
-config BR2_TARGET_ROOTFS_TAR_COPYTO
-       string "also copy the image to..."
-       depends on BR2_TARGET_ROOTFS_TAR
-       default ""
-       help
-         Copies the resulting image to a secondary location
-         like a tftp server's root directory.
-
-         Example: $(IMAGE)-$(DATE).tar
-
index d082672ced28b16c54d0f29db4884192bb7dd5f6..cd01bc74f72c97877ba7c7f3761b2da4f63b5fe9 100644 (file)
@@ -21,7 +21,6 @@ ifeq ($(BR2_TARGET_ROOTFS_TAR_LZMA),y)
 TAR_COMPRESSOR:=lzma -9 -c
 TAR_COMPRESSOR_EXT:=lzma
 endif
-ROOTFS_TAR_COPYTO:=$(call qstrip,$(BR2_TARGET_ROOTFS_TAR_COPYTO))
 
 tarroot: host-fakeroot makedevs
        # Use fakeroot to pretend all target binaries are owned by root
@@ -42,9 +41,6 @@ endif
 ifneq ($(TAR_COMPRESSOR),)
        -rm -f $(TAR_TARGET).$()
        PATH="$(STAGING_DIR)/sbin:$(STAGING_DIR)/bin:$(STAGING_DIR)/usr/sbin:$(STAGING_DIR)/usr/bin:$(PATH)" $(TAR_COMPRESSOR) $(TAR_TARGET) > $(TAR_TARGET).$(TAR_COMPRESSOR_EXT)
-endif
-ifneq ($(ROOTFS_TAR_COPYTO),)
-       $(Q)cp -f $(TAR_TARGET) $(ROOTFS_TAR_COPYTO)
 endif
        -@rm -f $(BUILD_DIR)/_fakeroot.$(notdir $(TAR_TARGET))
 
index 1ce1ab01807eafaab4641994ae8041ba331c3952..3222fea7b778df1ad8ae4db36b053b18f9130f55 100644 (file)
@@ -91,11 +91,3 @@ config BR2_TARGET_ROOTFS_UBIFS_LZMA
 
 endchoice
 
-config BR2_TARGET_ROOTFS_UBIFS_COPYTO
-       string "also copy the image to..."
-       depends on BR2_TARGET_ROOTFS_UBIFS
-       default ""
-       help
-         Copies the resulting image to a secondary location
-         like a tftp server's root directory.
-
index b48e10fd148a125d4761da293dd9bd808ae4e7ec..d0f3885f4160a743b1510121f1bd8a1e5482680f 100644 (file)
@@ -64,13 +64,8 @@ $(UBIFS_BASE).$(UBIFS_ROOTFS_COMPRESSOR_EXT): $(UBIFS_ROOTFS_COMPRESSOR_PREREQ)
        $(UBIFS_ROOTFS_COMPRESSOR) $(UBIFS_BASE) > $(UBIFS_TARGET)
 endif
 
-UBIFS_COPYTO := $(call qstrip,$(BR2_TARGET_ROOTFS_UBIFS_COPYTO))
-
 ubifsroot: $(UBIFS_TARGET)
        @ls -l $(UBIFS_TARGET)
-ifneq ($(UBIFS_COPYTO),)
-       @cp -f $(UBIFS_TARGET) $(UBIFS_COPYTO)
-endif
 
 #############################################################
 #