tyler writes:
authorEric Andersen <andersen@codepoet.org>
Thu, 6 Apr 2006 17:40:47 +0000 (17:40 -0000)
committerEric Andersen <andersen@codepoet.org>
Thu, 6 Apr 2006 17:40:47 +0000 (17:40 -0000)
Building DirectFB compiles fine and installs fine, but when running on the
target the libraries look for DirectFB modules within a path that was defined
as $(PREFIX) during the build. Under buildroot PREFIX is set to
$(STAGING_DIR)/usr, which obviously doesn't exist on the target so it dies.

Instead, it should be built such that PREFIX=/usr then have prefix &
exec_prefix set to $(STAGING_DIR)/usr when it's time to install.

package/directfb/directfb.mk

index 9ff293ade07e8c7e2ce2c2772e9fb92f8a3469ff..51062a865f7e13cfbddd34b8e8d7ceaa0c063642 100644 (file)
@@ -30,7 +30,7 @@ $(DIRECTFB_DIR)/.configured: $(DIRECTFB_DIR)/.unpacked
        --target=$(GNU_TARGET_NAME) \
        --host=$(GNU_TARGET_NAME) \
        --build=$(GNU_HOST_NAME) \
-       --prefix=$(STAGING_DIR)/usr \
+       --prefix=/usr \
        --with-gfxdrivers=cle266,unichrome \
        --enable-jpeg \
        --enable-png \
@@ -48,7 +48,7 @@ $(DIRECTFB_DIR)/.compiled: $(DIRECTFB_DIR)/.configured
        touch $(DIRECTFB_DIR)/.compiled
 
 $(STAGING_DIR)/usr/lib/libdirectfb.so: $(DIRECTFB_DIR)/.compiled
-       $(MAKE) -C $(DIRECTFB_DIR) install
+       $(MAKE) -C $(DIRECTFB_DIR) install prefix=$(STAGING_DIR)/usr exec_prefix=$(STAGING_DIR)/usr
        touch -c $(STAGING_DIR)/lib/libdirectfb.so
 
 $(TARGET_DIR)/usr/lib/libdirectfb.so: $(STAGING_DIR)/usr/lib/libdirectfb.so