pppd.mk installs radattr.so twice and omits radrealms.so
authorDarcy Watkins <dwatkins@tranzeo.com>
Thu, 19 Aug 2010 19:19:17 +0000 (12:19 -0700)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 29 Aug 2010 21:08:59 +0000 (23:08 +0200)
In pppd.mk the radattr.so plugin (for radiua) is installed twice (the second
install overwriting the first) but the radrealms.so plugin is omitted from
the install. This appears to be a copy-paste error.

Below is patch that corrects this.

signed-off by: Darcy Watkins <dwatkins@tranzeo.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/pppd/pppd.mk

diff --git a/CHANGES b/CHANGES
index 317e9e69cd43181d3568e0b1e75d1e93c9515539..8550b6f712e329e3392e676994e6cc4897076dc5 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -18,7 +18,7 @@
        fs: old-style squashfs for big endian archs fixed.
 
        Updated/fixed packages: busybox, imagemagick, libglib2, lua,
-       luafilesystem, lzo, netcat, php, proftpd, qt, samba,
+       luafilesystem, lzo, netcat, php, pppd, proftpd, qt, samba,
        startup-notification, sysvinit, util-linux
 
        Removed packages: stunnel
index 9d081f21ac6d54d3eb864c8a669fef0fc04cc09c..35fd451d767fcd3ea828b6cbd5346c9cfa5da1c1 100644 (file)
@@ -55,8 +55,8 @@ $(PPPD_TARGET_INSTALL_TARGET):
                $(TARGET_DIR)/usr/lib/pppd/$(PPPD_VERSION)/radattr.so
        $(INSTALL) -D $(PPPD_DIR)/pppd/plugins/radius/radius.so \
                $(TARGET_DIR)/usr/lib/pppd/$(PPPD_VERSION)/radius.so
-       $(INSTALL) -D $(PPPD_DIR)/pppd/plugins/radius/radattr.so \
-               $(TARGET_DIR)/usr/lib/pppd/$(PPPD_VERSION)/radattr.so
+       $(INSTALL) -D $(PPPD_DIR)/pppd/plugins/radius/radrealms.so \
+               $(TARGET_DIR)/usr/lib/pppd/$(PPPD_VERSION)/radrealms.so
        for m in $(PPPD_MANPAGES); do \
                $(INSTALL) -m 644 -D $(PPPD_DIR)/$$m/$$m.8 \
                        $(TARGET_DIR)/usr/share/man/man8/$$m.8; \