linux: restrict output image formats to the appropriate arches
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 1 Sep 2010 13:26:24 +0000 (15:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 28 Sep 2010 22:14:21 +0000 (00:14 +0200)
Some Linux kernel output image formats are available on some archs,
some not. For example 'uImage' is not supported on MIPS, so let's
prevent the user from making this selection.

Issue initially reported by Choi, David <David.Choi@Micrel.Com>.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/Config.in
linux/linux.mk

index a7109a5071f7a7248057da237b1f440a22cb1053..1e015b7fca9f625126d5bff5cbb53db4ca68ae3f 100644 (file)
@@ -111,20 +111,22 @@ config BR2_LINUX_KERNEL_CUSTOM_CONFIG_FILE
 
 choice
        prompt "Kernel binary format"
-       default BR2_LINUX_KERNEL_UIMAGE if !BR2_i386 && !BR2_x86_64
-       default BR2_LINUX_KERNEL_BZIMAGE if BR2_i386 || BR2_x86_64
 
 config BR2_LINUX_KERNEL_UIMAGE
        bool "uImage"
+       depends on BR2_arm || BR2_armeb || BR2_powerpc || BR2_avr32 || BR2_sh || BR2_sh64
 
 config BR2_LINUX_KERNEL_BZIMAGE
        bool "bzImage"
+       depends on BR2_i386 || BR2_x86_64
 
 config BR2_LINUX_KERNEL_ZIMAGE
        bool "zImage"
+       depends on BR2_arm || BR2_armeb || BR2_powerpc || BR2_sparc || BR2_sh || BR2_sh64 || BR2_xtensa
 
-config BR2_LINUX_KERNEL_VMLINUX
-       bool "vmlinux"
+config BR2_LINUX_KERNEL_VMLINUX_BIN
+       bool "vmlinux.bin"
+       depends on BR2_mips || BR2_mipsel || BR2_sh || BR2_sh64
 
 endchoice
 
index aabecc1f65c9afc88d8cb1d33931025baa00aae8..4490023a42e746dcd045b5e573541156fd590917 100644 (file)
@@ -38,7 +38,7 @@ else ifeq ($(BR2_LINUX_KERNEL_BZIMAGE),y)
 LINUX26_IMAGE_NAME=bzImage
 else ifeq ($(BR2_LINUX_KERNEL_ZIMAGE),y)
 LINUX26_IMAGE_NAME=zImage
-else ifeq ($(BR2_LINUX_KERNEL_VMLINUX),y)
+else ifeq ($(BR2_LINUX_KERNEL_VMLINUX_BIN),y)
 LINUX26_IMAGE_NAME=vmlinux.bin
 endif