package/libump: remove package
authorFrancois Perrad <fperrad@gmail.com>
Wed, 6 Mar 2019 15:24:26 +0000 (16:24 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 15 Mar 2019 22:18:23 +0000 (23:18 +0100)
This library was previously a part of sunxi-mali.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Config.in.legacy
DEVELOPERS
package/Config.in
package/libump/Config.in [deleted file]
package/libump/libump.hash [deleted file]
package/libump/libump.mk [deleted file]
package/x11r7/xdriver_xf86-video-fbturbo/xdriver_xf86-video-fbturbo.mk

index c094f07584520a3e26fd2a72a16d7e04dad60fcb..2030b51e1d530b7d9588f12c02732c9d3a7d6fd2 100644 (file)
@@ -146,6 +146,13 @@ endif
 
 comment "Legacy options removed in 2019.05"
 
+config BR2_PACKAGE_LIBUMP
+       bool "libump package removed"
+       select BR2_LEGACY
+       help
+         The libump package was removed, it was only used as a
+         dependency of sunxi-mali, which itself was removed.
+
 config BR2_PACKAGE_SUNXI_MALI
        bool "sunxi-mali package removed"
        select BR2_LEGACY
index 62ad09950b4aade7fc28866e7b0fa459f8c00e4b..778dffa5d50c61b9edb96fa280fe6c57bc2e22b9 100644 (file)
@@ -843,7 +843,6 @@ F:  package/ficl/
 F:     package/gdbm/
 F:     package/libtomcrypt/
 F:     package/libtommath/
-F:     package/libump/
 F:     package/libwpe/
 F:     package/linenoise/
 F:     package/ljlinenoise/
index b8c57d34eb57b28baeb153b349ef785d69905b43..30391cfc890034a19baab630bc88ee63204ef6eb 100644 (file)
@@ -454,7 +454,6 @@ endmenu
        source "package/kbd/Config.in"
        source "package/lcdproc/Config.in"
        source "package/libuio/Config.in"
-       source "package/libump/Config.in"
        source "package/linuxconsoletools/Config.in"
        source "package/linux-backports/Config.in"
        source "package/lirc-tools/Config.in"
diff --git a/package/libump/Config.in b/package/libump/Config.in
deleted file mode 100644 (file)
index 696ccf3..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-config BR2_PACKAGE_LIBUMP
-       bool "libump"
-       depends on BR2_TOOLCHAIN_USES_GLIBC
-       depends on BR2_arm
-       help
-         The ARMs Universal Memory Provider userspace library.
-         This library is a requirement for ARMs binary Mali driver.
-
-         http://github.com/linux-sunxi/libump
-
-comment "libump needs a glibc toolchain"
-       depends on BR2_arm
-       depends on !BR2_TOOLCHAIN_USES_GLIBC
diff --git a/package/libump/libump.hash b/package/libump/libump.hash
deleted file mode 100644 (file)
index 5d2ad2e..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-# locally computed
-sha256  745bbb3e6a6b2b1d8caec75d2f2e884691ceefa5c2be0480baed31dba66cf450  libump-ec0680628744f30b8fac35e41a7bd8e23e59c39f.tar.gz
diff --git a/package/libump/libump.mk b/package/libump/libump.mk
deleted file mode 100644 (file)
index 65012ff..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-################################################################################
-#
-# libump
-#
-################################################################################
-
-LIBUMP_VERSION = ec0680628744f30b8fac35e41a7bd8e23e59c39f
-LIBUMP_SITE = $(call github,linux-sunxi,libump,$(LIBUMP_VERSION))
-LIBUMP_LICENSE = Apache-2.0
-LIBUMP_AUTORECONF = YES
-LIBUMP_INSTALL_STAGING = YES
-
-$(eval $(autotools-package))
index 58a70416dd2bd19d02a01e9f23635804856a89c5..049a2b5be15b7d8ee3c32fc88d3d4610d87ca2f7 100644 (file)
@@ -21,10 +21,6 @@ else
 XDRIVER_XF86_VIDEO_FBTURBO_CONF_OPTS += --disable-pciaccess
 endif
 
-ifeq ($(BR2_PACKAGE_LIBUMP),y)
-XDRIVER_XF86_VIDEO_FBTURBO_DEPENDENCIES += libump
-endif
-
 define XDRIVER_XF86_VIDEO_FBTURBO_INSTALL_CONF_FILE
        $(INSTALL) -m 0644 -D $(@D)/xorg.conf $(TARGET_DIR)/etc/X11/xorg.conf
 endef