package/systemd: disable audit for host package
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 29 Aug 2020 13:59:41 +0000 (15:59 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 29 Aug 2020 16:34:54 +0000 (18:34 +0200)
Disable audit for host package to avoid getting the following error if
it is found on host:

[84/662] Generating audit_type-list.txt with a meson_exe.py custom command
In file included from <command-line>:32:
./../src/basic/missing_audit.h:7:10: fatal error: libaudit.h: No such file or directory
    7 | #include <libaudit.h>
      |          ^~~~~~~~~~~~

Fixes:
 - http://autobuild.buildroot.org/results/67782c225c08387c1bbcbea9eee3ca12bc6577cd

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/systemd/systemd.mk

index 115ccbda06f64eb4088c0552713ad21b944216d7..81fa2bd0f05af0fc2b5b9d3b87826b764fdabf0d 100644 (file)
@@ -700,7 +700,8 @@ HOST_SYSTEMD_CONF_OPTS = \
        -Dxdg-autostart=false \
        -Dkernel-install=false \
        -Dsystemd-analyze=false \
-       -Dlibcryptsetup=false
+       -Dlibcryptsetup=false \
+       -Daudit=false
 
 HOST_SYSTEMD_DEPENDENCIES = \
        $(BR2_COREUTILS_HOST_DEPENDENCY) \