libglib2: remove fix-clock-gettime patch
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 3 Oct 2010 08:14:19 +0000 (10:14 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 18 Oct 2010 13:26:05 +0000 (09:26 -0400)
This patch was introduced in 0ec4298153bd93f8d7efbd1890896fbac5046a7b
to fix a problem in libglib configure script when using the
configuration cache.

However, we decided that the shared configuration cache cannot work
reliably, to disable it by default, and probably to remove it
altogether. So just drop this patch, and don't autoreconfigure
libglib.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libglib2/libglib2-fix-clock-gettime-check.patch [deleted file]
package/libglib2/libglib2.mk

diff --git a/package/libglib2/libglib2-fix-clock-gettime-check.patch b/package/libglib2/libglib2-fix-clock-gettime-check.patch
deleted file mode 100644 (file)
index f336ea5..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-Rework clock_gettime() test
-
-The test for clock_gettime() in configure.ac doesn't work properly
-when a previous package has loaded the shared configuration cache with
-informations about the availability of clock_gettime. A package such
-as ctorrent does so, which means that compiling ctorrent *then*
-libglib2 currently fails.
-
-According to people on the Autoconf mailing list, the libglib2 test is
-likely the one that needs to be fixed. The problem is that the
-AC_CHECK_FUNCS() test assumes that if it finds clock_gettime() it
-means that there's no need to add any -lrt flag to the
-build. Unfortunately, due to the shared configuration cache, this test
-is already done with -lrt, so the test succeeds, and libglib2 does not
-know that it needs to add -lrt to G_THREAD_LIBS and
-G_THREAD_LIBS_FOR_GTHREAD.
-
-So instead, we remplace the test with an AC_SEARCH_LIBS() test,
-followed by a test on the result of this AC_SEARCH_LIBS() test to add
-the necessary -lrt to G_THREAD_LIBS and
-G_THREAD_LIBS_FOR_GTHREAD. Therefore, even if the result for the
-AC_SEARCH_LIBS() test is cached due to the prior execution ctorrent
-./configure script, libglib2 ./configure will properly add -lrt to the
-appropriate variables.
-
-Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-
----
- configure.ac |   11 ++++++-----
- 1 file changed, 6 insertions(+), 5 deletions(-)
-
-Index: glib-2.26.0/configure.ac
-===================================================================
---- glib-2.26.0.orig/configure.ac
-+++ glib-2.26.0/configure.ac
-@@ -2379,13 +2379,14 @@
-       LIBS="$glib_save_LIBS"
- fi
--AC_CHECK_FUNCS(clock_gettime, [], [
--  AC_CHECK_LIB(rt, clock_gettime, [
--    AC_DEFINE(HAVE_CLOCK_GETTIME, 1)
-+AC_SEARCH_LIBS([clock_gettime], [rt], [
-+    AC_DEFINE(HAVE_CLOCK_GETTIME, 1,[Have clock_gettime])
-+])
-+
-+if test "$ac_cv_search_clock_gettime" = "-lrt"; then
-     G_THREAD_LIBS="$G_THREAD_LIBS -lrt"
-     G_THREAD_LIBS_FOR_GTHREAD="$G_THREAD_LIBS_FOR_GTHREAD -lrt"
--  ])
--])
-+fi
- AC_CACHE_CHECK(for monotonic clocks,
-     glib_cv_monotonic_clock,AC_COMPILE_IFELSE([AC_LANG_SOURCE([[
index 1468af17365ec78fdff60bbe50a76fe3f8618126..0d44d71627879dce68d5afc3c3475deb34df508f 100644 (file)
@@ -9,7 +9,6 @@ LIBGLIB2_VERSION = $(LIBGLIB2_VERSION_MAJOR).$(LIBGLIB2_VERSION_MINOR)
 LIBGLIB2_SOURCE = glib-$(LIBGLIB2_VERSION).tar.bz2
 LIBGLIB2_SITE = http://ftp.gnome.org/pub/gnome/sources/glib/$(LIBGLIB2_VERSION_MAJOR)
 
-LIBGLIB2_AUTORECONF = YES
 LIBGLIB2_LIBTOOL_PATCH = NO
 LIBGLIB2_INSTALL_STAGING = YES
 LIBGLIB2_INSTALL_TARGET = YES