package/iputils: update path for tftpd
authorPetr Vorel <petr.vorel@gmail.com>
Sat, 6 Feb 2021 18:56:40 +0000 (18:56 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 6 Feb 2021 22:00:34 +0000 (23:00 +0100)
tftpd has been installed into /usr/sbin in 20210202
(in upstream commit 8d1420f tftpd: install into sbindir).

Thus remove hook which expected it in /usr/bin and tried to move it into
/usr/sbin.

Fixes:
 - http://autobuild.buildroot.net/results/3d142a705f07d496b1342e04094cd03ce7d92994
 - http://autobuild.buildroot.net/results/dae643b2d23d74b5f91225d00e85c350861a0e8a
 - http://autobuild.buildroot.net/results/dcfcb082bc188e7f990e280c3fd5d971f32cc048

Fixes: ea422f9950 ("package/iputils: bump version to 20210202")
Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/iputils/iputils.mk

index 0273e295d6d2e9f397dfdd5f151f35a03473b60e..1ee64dabe49f724040fd6e47457d289b46b2b551 100644 (file)
@@ -84,11 +84,6 @@ endif
 ifeq ($(BR2_PACKAGE_IPUTILS_TFTPD),y)
 IPUTILS_CONF_OPTS += -DBUILD_TFTPD=true
 
-define IPUTILS_MOVE_TFTPD_BINARY
-       mv $(TARGET_DIR)/usr/bin/tftpd $(TARGET_DIR)/usr/sbin/tftpd
-endef
-IPUTILS_POST_INSTALL_TARGET_HOOKS += IPUTILS_MOVE_TFTPD_BINARY
-
 else
 IPUTILS_CONF_OPTS += -DBUILD_TFTPD=false
 endif