bitstream-vera: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 11 Apr 2015 10:51:14 +0000 (07:51 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 11 Apr 2015 13:17:15 +0000 (15:17 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/bitstream-vera/Config.in [new file with mode: 0644]
package/bitstream-vera/bitstream-vera.hash [new file with mode: 0644]
package/bitstream-vera/bitstream-vera.mk [new file with mode: 0644]

index a996855a660d0c3c400ae2a71f808f4676628f46..2c84c3fb248f6ce4a397c0842f75fb2e065f7d36 100644 (file)
@@ -179,6 +179,7 @@ endmenu
 menu "Fonts, icons, sounds and themes"
 
 comment "Fonts"
+       source "package/bitstream-vera/Config.in"
        source "package/dejavu/Config.in"
        source "package/ghostscript-fonts/Config.in"
        source "package/liberation/Config.in"
diff --git a/package/bitstream-vera/Config.in b/package/bitstream-vera/Config.in
new file mode 100644 (file)
index 0000000..034f115
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_BITSTREAM_VERA
+       bool "Bitstream Vera"
+       help
+         Bitstream Vera font family.
+
+         https://www.gnome.org/fonts/
diff --git a/package/bitstream-vera/bitstream-vera.hash b/package/bitstream-vera/bitstream-vera.hash
new file mode 100644 (file)
index 0000000..e18b38b
--- /dev/null
@@ -0,0 +1,2 @@
+# From http://ftp.gnome.org/pub/GNOME/sources/ttf-bitstream-vera/1.10/ttf-bitstream-vera-1.10.tar.bz2.sha256sum
+sha256 db5b27df7bbb318036ebdb75acd3e98f1bd6eb6608fb70a67d478cd243d178dc        ttf-bitstream-vera-1.10.tar.bz2
diff --git a/package/bitstream-vera/bitstream-vera.mk b/package/bitstream-vera/bitstream-vera.mk
new file mode 100644 (file)
index 0000000..f487d63
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# bitstream-vera
+#
+################################################################################
+
+BITSTREAM_VERA_VERSION = 1.10
+BITSTREAM_VERA_SITE = http://ftp.gnome.org/pub/GNOME/sources/ttf-bitstream-vera/$(BITSTREAM_VERA_VERSION)
+BITSTREAM_VERA_SOURCE = ttf-bitstream-vera-$(BITSTREAM_VERA_VERSION).tar.bz2
+BITSTREAM_VERA_TARGET_DIR = $(TARGET_DIR)/usr/share/fonts/ttf-bitstream-vera
+BITSTREAM_VERA_LICENSE = BitstreamVera
+BITSTREAM_VERA_LICENSE_FILES = COPYRIGHT.TXT
+
+define BITSTREAM_VERA_INSTALL_TARGET_CMDS
+       mkdir -p $(BITSTREAM_VERA_TARGET_DIR)
+       $(INSTALL) -m 644 $(@D)/*.ttf $(BITSTREAM_VERA_TARGET_DIR)
+endef
+
+$(eval $(generic-package))