fs: make it behave a bit more like the package infra
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 28 Dec 2017 10:40:32 +0000 (11:40 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 3 Jan 2018 20:58:07 +0000 (21:58 +0100)
Currently, to register a filesystem, one has to call:

    $(eval $(call ROOTFS_TARGET,blabla))

This is very unlike the package infrastructure, where the name of the
package is automatically guessed by the infra.

It turns out that we can now do that for the filesystem infra too.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
14 files changed:
fs/axfs/axfs.mk
fs/cloop/cloop.mk
fs/common.mk
fs/cpio/cpio.mk
fs/cramfs/cramfs.mk
fs/ext2/ext2.mk
fs/iso9660/iso9660.mk
fs/jffs2/jffs2.mk
fs/romfs/romfs.mk
fs/squashfs/squashfs.mk
fs/tar/tar.mk
fs/ubi/ubi.mk
fs/ubifs/ubifs.mk
fs/yaffs2/yaffs.mk

index 6c795d706224ec1c760a5bd6731a82daaa4c8f15..4b93df55c083f13b4ce480a9cfcd3fda1f99656d 100644 (file)
@@ -10,4 +10,4 @@ define ROOTFS_AXFS_CMD
        $(HOST_DIR)/bin/mkfs.axfs -s -a $(TARGET_DIR) $@
 endef
 
-$(eval $(call ROOTFS_TARGET,axfs))
+$(eval $(rootfs))
index cbfc79b0d1ce7c933f988956d7689ac136c0dbe1..17749c5a3b9215eb01e7e7f0785a042d1c118757 100644 (file)
@@ -11,4 +11,4 @@ define ROOTFS_CLOOP_CMD
                $(HOST_DIR)/bin/create_compressed_fs - 65536 > $@
 endef
 
-$(eval $(call ROOTFS_TARGET,cloop))
+$(eval $(rootfs))
index b06e9b5597fb6bc96c7734b4b4f4214e7b6444cc..98232f0b9f9ab7140fbad9740a6efc2f582763e2 100644 (file)
@@ -37,7 +37,7 @@ ROOTFS_USERS_TABLES = $(call qstrip,$(BR2_ROOTFS_USERS_TABLES))
 
 # Since this function will be called from within an $(eval ...)
 # all variable references except the arguments must be $$-quoted.
-define ROOTFS_TARGET_INTERNAL
+define inner-rootfs
 
 # extra deps
 ROOTFS_$(2)_DEPENDENCIES += host-fakeroot host-makedevs \
@@ -128,8 +128,7 @@ endif
 
 endef
 
-define ROOTFS_TARGET
-       $(call ROOTFS_TARGET_INTERNAL,$(1),$(call UPPERCASE,$(1)))
-endef
+# $(pkgname) also works well to return the filesystem name
+rootfs = $(call inner-rootfs,$(pkgname),$(call UPPERCASE,$(pkgname)))
 
 include $(sort $(wildcard fs/*/*.mk))
index c68e0bfb97d2421bdc5b5f660a8c1229fed8c9c6..aa4d947fa56c37bc4f7b863703c82a8060f008f9 100644 (file)
@@ -40,4 +40,4 @@ endef
 ROOTFS_CPIO_POST_GEN_HOOKS += ROOTFS_CPIO_UBOOT_MKIMAGE
 endif
 
-$(eval $(call ROOTFS_TARGET,cpio))
+$(eval $(rootfs))
index 85b98b8ccd9a7aecf918f96840bbd274dd7c1ea3..f880871935f0a8db29c461546dc5b95892955c80 100644 (file)
@@ -16,4 +16,4 @@ endef
 
 ROOTFS_CRAMFS_DEPENDENCIES = host-cramfs
 
-$(eval $(call ROOTFS_TARGET,cramfs))
+$(eval $(rootfs))
index 12b87a722c6c0384f2bd2a11fb73e0644c3b7b28..6bb4b1c7f8e96901e3d384debbeb52b443473504 100644 (file)
@@ -43,4 +43,4 @@ endef
 ROOTFS_EXT2_POST_GEN_HOOKS += ROOTFS_EXT2_SYMLINK
 endif
 
-$(eval $(call ROOTFS_TARGET,ext2))
+$(eval $(rootfs))
index 38ed3cd970ecf1dd5bf4567a4af9f97bf78b9f8b..207c6aa39f43fbe934a70f345df21de99c8c2789 100644 (file)
@@ -144,4 +144,4 @@ endef
 ROOTFS_ISO9660_POST_GEN_HOOKS += ROOTFS_ISO9660_GEN_HYBRID
 endif
 
-$(eval $(call ROOTFS_TARGET,iso9660))
+$(eval $(rootfs))
index 9a36a75ff4a416cb34bbd055753ff9adbd5960e4..740ab3e03d79e87e7b3b19ed026a83a8453a122b 100644 (file)
@@ -49,4 +49,4 @@ define ROOTFS_JFFS2_CMD
 endef
 endif
 
-$(eval $(call ROOTFS_TARGET,jffs2))
+$(eval $(rootfs))
index eded91df0adc13a12c73a22be710b7af614c75b7..163751b4e2eee00dfbc131ac2477b07c60c01814 100644 (file)
@@ -10,4 +10,4 @@ define ROOTFS_ROMFS_CMD
        $(HOST_DIR)/bin/genromfs -d $(TARGET_DIR) -f $@
 endef
 
-$(eval $(call ROOTFS_TARGET,romfs))
+$(eval $(rootfs))
index 7de7f51af1ad16facc08aedef240123a5e5a3322..51abd5d7d0e44e8ba51e63ae7ba33d882579c721 100644 (file)
@@ -24,4 +24,4 @@ define ROOTFS_SQUASHFS_CMD
        $(HOST_DIR)/bin/mksquashfs $(TARGET_DIR) $@ $(ROOTFS_SQUASHFS_ARGS)
 endef
 
-$(eval $(call ROOTFS_TARGET,squashfs))
+$(eval $(rootfs))
index 0e3eacbedf05db615d39628a02ecc095e1a55317..e39c2fdbf1e347a473511d4b834f2912047882ea 100644 (file)
@@ -11,4 +11,4 @@ define ROOTFS_TAR_CMD
                tar $(TAR_OPTS) -cf $@ --null --no-recursion -T - --numeric-owner)
 endef
 
-$(eval $(call ROOTFS_TARGET,tar))
+$(eval $(rootfs))
index b71a555efbbce7257be44bbcddb9522f555c6071..c78feda5a353d817b26ad270ecfe91db55a6b457 100644 (file)
@@ -29,4 +29,4 @@ define ROOTFS_UBI_CMD
        rm $(BUILD_DIR)/ubinize.cfg
 endef
 
-$(eval $(call ROOTFS_TARGET,ubi))
+$(eval $(rootfs))
index 4f45acdc4a789a6ec797b12fff7dc7ef1d9e1a3a..2cfc397aca6c7be9fdc3a7eb9d46d347f5ffacf6 100644 (file)
@@ -27,4 +27,4 @@ define ROOTFS_UBIFS_CMD
        $(HOST_DIR)/sbin/mkfs.ubifs -d $(TARGET_DIR) $(UBIFS_OPTS) -o $@
 endef
 
-$(eval $(call ROOTFS_TARGET,ubifs))
+$(eval $(rootfs))
index 30570735fade140f882d65b34b2aed1d72179e41..9cba27af70763cc2239642ec7adf77a4800062fc 100644 (file)
@@ -10,4 +10,4 @@ define ROOTFS_YAFFS2_CMD
        $(HOST_DIR)/bin/mkyaffs2 --all-root $(TARGET_DIR) $@
 endef
 
-$(eval $(call ROOTFS_TARGET,yaffs2))
+$(eval $(rootfs))