cups: add host-pkgconf as a dependency
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 14 Feb 2017 20:47:59 +0000 (21:47 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 14 Feb 2017 21:14:32 +0000 (22:14 +0100)
cups configure script checks for a pkg-config program. If host-pkgconf
has not been built prior to cups, it uses the system pkg-config, which
might potentially lead to bogus results:

checking for i586-buildroot-linux-musl-pkg-config... no
checking for pkg-config... /usr/bin/pkg-config

With this patch applied:

checking for i586-buildroot-linux-musl-pkg-config... no
checking for pkg-config... /home/thomas/projets/buildroot/output/host/usr/bin/pkg-config

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/cups/cups.mk

index 05737767f82b8b3435d2c457de14207e108b8b13..7ef2f36a2254328d1f19b8d82c57025fb9de8b36 100644 (file)
@@ -28,6 +28,7 @@ CUPS_CONF_OPTS = \
 CUPS_CONFIG_SCRIPTS = cups-config
 CUPS_DEPENDENCIES = \
        host-autoconf \
+       host-pkgconf \
        $(if $(BR2_PACKAGE_ZLIB),zlib)
 
 ifeq ($(BR2_PACKAGE_SYSTEMD),y)