package/go: Fix powerpc64 config typo
authorGeoff Levand <geoff@infradead.org>
Thu, 12 May 2016 00:08:47 +0000 (00:08 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 12 May 2016 14:21:04 +0000 (16:21 +0200)
Fix typo in config powerpc64 depends.  Go language only supports 64 bit powerpc.

Also add BR2_powerpc64le to depends list.

Signed-off-by: Geoff Levand <geoff@infradead.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/go/Config.in.host
package/go/go.mk

index 094e402949acf352d3752020644de679135beda8..b57080399ad3b6c88508373011f7de5cef31aacc 100644 (file)
@@ -1,5 +1,5 @@
 config BR2_PACKAGE_HOST_GO_ARCH_SUPPORTS
        bool
        default y
-       depends on BR2_arm || BR2_aarch64 || BR2_i386 || BR2_x86_64 || BR2_powerpc
+       depends on BR2_arm || BR2_aarch64 || BR2_i386 || BR2_x86_64 || BR2_powerpc64 || BR2_powerpc64le
        depends on !BR2_ARM_CPU_ARMV4
index 720c75a56e55c4c346afde09561a7509f3e1dc89..a9e16dd4a483e514ae237c56fe0654bfece756fb 100644 (file)
@@ -26,8 +26,10 @@ else ifeq ($(BR2_i386),y)
 GO_GOARCH = 386
 else ifeq ($(BR2_x86_64),y)
 GO_GOARCH = amd64
-else ifeq ($(BR2_powerpc),y)
+else ifeq ($(BR2_powerpc64),y)
 GO_GOARCH = ppc64
+else ifeq ($(BR2_powerpc64le),y)
+GO_GOARCH = ppc64le
 endif
 
 HOST_GO_DEPENDENCIES = host-go-bootstrap