package/mesa3d: add option to configure gbm support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 2 Feb 2020 17:33:32 +0000 (18:33 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 3 Feb 2020 10:42:42 +0000 (11:42 +0100)
Kodi 18.0-Leia implements stand-alone gbm support alongside x11 &
wayland. To enable building gbm support in mesa3d without x11 &
wayland we need to add a specific configure option for it.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/mesa3d/Config.in
package/mesa3d/mesa3d.mk

index 14adb407b4c249f93b2aa6eddfa55270e2a996d4..5929e15442912e1d3b8fd25c945ecd56422965cd 100644 (file)
@@ -355,6 +355,11 @@ if BR2_PACKAGE_MESA3D_DRIVER
 
 comment "OpenGL API Support"
 
+config BR2_PACKAGE_MESA3D_GBM
+       bool "gbm"
+       help
+         Enable Generic Buffer Management (gbm)
+
 config BR2_PACKAGE_MESA3D_OPENGL_GLX
        bool "OpenGL GLX"
        depends on BR2_PACKAGE_XORG7
@@ -370,6 +375,7 @@ config BR2_PACKAGE_MESA3D_OPENGL_EGL
        bool "OpenGL EGL"
        select BR2_PACKAGE_HAS_LIBEGL
        select BR2_PACKAGE_HAS_LIBEGL_WAYLAND
+       select BR2_PACKAGE_MESA3D_GBM
        help
          Use the Khronos EGL APIs. EGL is a window manager for OpenGL
          applications similar to GLX, for X, and WGL, for Windows.
index f0e889a400aa7eb0016e9424f88e02ed1d797ea1..c7e5be55a008d169a9785409dc44edf5e9d9a2fb 100644 (file)
@@ -200,10 +200,17 @@ endif
 MESA3D_CONF_OPTS += \
        -Dplatforms=$(subst $(space),$(comma),$(MESA3D_PLATFORMS))
 
+ifeq ($(BR2_PACKAGE_MESA3D_GBM),y)
+MESA3D_CONF_OPTS += \
+       -Dgbm=true
+else
+MESA3D_CONF_OPTS += \
+       -Dgbm=false
+endif
+
 ifeq ($(BR2_PACKAGE_MESA3D_OPENGL_EGL),y)
 MESA3D_PROVIDES += libegl
 MESA3D_CONF_OPTS += \
-       -Dgbm=true \
        -Degl=true
 else
 MESA3D_CONF_OPTS += \