tcl: specify ln -sf to remove existing destination file
authorAxel Lin <axel.lin@ingics.com>
Mon, 14 Oct 2013 13:23:02 +0000 (21:23 +0800)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 14 Oct 2013 20:00:13 +0000 (22:00 +0200)
This fixes below build error when executing
"make tcl-dirclean; make tcl-rebuild".

ln -s tclsh8.4 /opt/test/br-x86/buildroot/output/target/usr/bin/tclsh
ln: failed to create symbolic link '/opt/test/br-x86/buildroot/output/target/usr/bin/tclsh': File exists
make: *** [/opt/test/br-x86/buildroot/output/build/tcl-8.4.19/.stamp_target_installed] Error 1

Signed-off-by: Axel Lin <axel.lin@ingics.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tcl/tcl.mk

index 3291c1b28d1cd6340ef9710c32a8f95f8ef41b02..58f085a207fab533c597191dda1188b2d24a2fd2 100644 (file)
@@ -37,7 +37,7 @@ endef
 TCL_POST_INSTALL_TARGET_HOOKS += TCL_REMOVE_TCLSH
 else
 define TCL_SYMLINK_TCLSH
-       ln -s tclsh$(TCL_VERSION_MAJOR) $(TARGET_DIR)/usr/bin/tclsh
+       ln -sf tclsh$(TCL_VERSION_MAJOR) $(TARGET_DIR)/usr/bin/tclsh
 endef
 TCL_POST_INSTALL_TARGET_HOOKS += TCL_SYMLINK_TCLSH
 endif