libevas: async image preload support needs threads support in toolchain
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 4 Sep 2013 11:31:19 +0000 (13:31 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 4 Sep 2013 11:31:19 +0000 (13:31 +0200)
Fixes http://autobuild.buildroot.net/results/92b/92b3990e3a51c9e400cff31a1f0d23aeb5085a54/

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/efl/libevas/libevas.mk

index 41ceb49cc9d0bfcc17a7c07b130982e5c8621b84..46de4cb4f7e95ec092057431e6ccd8cf809800ad 100644 (file)
@@ -203,6 +203,11 @@ else
 LIBEVAS_CONF_OPT += --disable-font-loader-eet
 endif
 
+# async image preload support needs threads support in toolchain
+ifneq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
+LIBEVAS_CONF_OPT += --disable-async-preload
+endif
+
 # libevas installs the source code of examples on the target, which
 # are generally not useful.
 define LIBEVAS_REMOVE_EXAMPLES