toolchain/external: only copy the pthread lib if needed
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>
Fri, 28 May 2010 21:23:14 +0000 (23:23 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 28 May 2010 21:31:15 +0000 (23:31 +0200)
If threads are disabled, do not try to copy the libpthread.so from the
external library.

It is still expected that the BR configuration matches the external
toolchain setup, and no check is done to enforce that.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/external-toolchain/ext-tool.mk

index bb4809ccdd2d866ed0590361fad41b7a88958a26..e858edb8c2f50393c66f02cb398156091dd3ec11 100644 (file)
@@ -251,7 +251,7 @@ check_cross_compiler_exists = \
 
 uclibc: dependencies $(STAMP_DIR)/ext-toolchain-installed
 
-EXTERNAL_LIBS=libc.so libcrypt.so libdl.so libgcc_s.so libm.so libnsl.so libpthread.so libresolv.so librt.so libutil.so
+EXTERNAL_LIBS=libc.so libcrypt.so libdl.so libgcc_s.so libm.so libnsl.so libresolv.so librt.so libutil.so
 ifeq ($(BR2_TOOLCHAIN_EXTERNAL_UCLIBC),y)
 EXTERNAL_LIBS+=ld-uClibc.so
 else
@@ -262,6 +262,10 @@ ifeq ($(BR2_INSTALL_LIBSTDCPP),y)
 EXTERNAL_LIBS+=libstdc++.so
 endif
 
+ifneq ($(BR2_PTHREADS_NONE),y)
+EXTERNAL_LIBS+=libpthread.so
+endif # ! no threads
+
 # SYSROOT_DIR selection. We first try the -print-sysroot option,
 # available in gcc 4.4.x and in some Codesourcery toolchains. If this
 # option is not available, we fallback to the value of --with-sysroot