toolchain/mips: kill EABI and fix N32
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sat, 14 Jul 2012 12:28:37 +0000 (09:28 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 14 Jul 2012 22:57:42 +0000 (00:57 +0200)
MIPS EABI is a bare-metal ABI so remove it.
Also fix uClibc to really work with N32 ABI, which used the EABI knob
previously.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
target/Config.in.arch
toolchain/uClibc/uclibc.mk

index c9bbc127749ef98aa0c5db0eccb874683f556a74..bad0f4caf8d991e02fcd0d42918bbeaf0a27b69d 100644 (file)
@@ -280,9 +280,6 @@ config BR2_MIPS_OABI32
 config BR2_MIPS_ABI32
        bool "n32"
        depends on BR2_mips_3 || BR2_mips_4 || BR2_mips_64 || BR2_mips_64r2 || BR2_mips_16
-config BR2_MIPS_EABI
-       bool "eabi"
-       depends on BR2_mips_3 || BR2_mips_4 || BR2_mips_64 || BR2_mips_64r2 || BR2_mips_16
 config BR2_MIPS_ABI64
        bool "n64"
        depends on BR2_mips_3 || BR2_mips_4 || BR2_mips_64 || BR2_mips_64r2 || BR2_mips_16
index f40fe365b0db63193ba0a92e1b0d07fd16bbbabb..9d0b6db94ac597f53a26e470b02da6bbadf32f9e 100644 (file)
@@ -158,7 +158,7 @@ ifeq ($(UCLIBC_TARGET_ARCH),mips)
 ifeq ($(BR2_MIPS_OABI),y)
        $(SED) 's/.*\(CONFIG_MIPS_O32_ABI\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
 endif
-ifeq ($(BR2_MIPS_EABI),y)
+ifeq ($(BR2_MIPS_ABI32),y)
        $(SED) 's/.*\(CONFIG_MIPS_N32_ABI\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
 endif
 ifeq ($(BR2_MIPS_ABI64),y)