openresolv: new package
authorParesh Chaudhary <paresh.chaudhary@rockwellcollins.com>
Tue, 14 Aug 2018 17:33:48 +0000 (12:33 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 14 Aug 2018 20:06:32 +0000 (22:06 +0200)
This patch added 'openresolv' package support. This tool
provides a dns management framework to track currently
available nameservers.

A key feature of this tool vs resolvconf is the ability to
manage multiple name server input configuration files and
generate the /etc/resolv.conf.  This is handy when you have
multiple dynamic communication paths providing nameserver
information.

REF: https://github.com/rsmarples/openresolv

Signed-off-by: Paresh Chaudhary <paresh.chaudhary@rockwellcollins.com>
signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/openresolv/Config.in [new file with mode: 0644]
package/openresolv/openresolv.hash [new file with mode: 0644]
package/openresolv/openresolv.mk [new file with mode: 0644]

index 5a1a66b1aebbf26a2eb833295156e952063f3678..9a2576ddc766f0d8a7050361e587e401009fe9ac 100644 (file)
@@ -1353,6 +1353,7 @@ F:        package/mtd/
 F:     package/mtools/
 F:     package/nginx-upload/
 F:     package/omniorb/
+F:     package/openresolv/
 F:     package/paxtest/
 F:     package/picocom/
 F:     package/policycoreutils/
index 7b4637900f887aea9a47318efef9ee2ad992443c..eda0f698dc5544345fdbe4f1df319110043e7540 100644 (file)
@@ -1866,6 +1866,7 @@ endif
        source "package/open-plc-utils/Config.in"
        source "package/openntpd/Config.in"
        source "package/openobex/Config.in"
+       source "package/openresolv/Config.in"
        source "package/openssh/Config.in"
        source "package/openswan/Config.in"
        source "package/openvpn/Config.in"
diff --git a/package/openresolv/Config.in b/package/openresolv/Config.in
new file mode 100644 (file)
index 0000000..2a393c6
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_OPENRESOLV
+       bool "openresolv"
+       help
+         openresolv is a resolvconf implementation which
+         manages resolv.conf. This tool provides a dns management
+         framework to track currently available nameservers.
+
+         https://github.com/rsmarples/openresolv
diff --git a/package/openresolv/openresolv.hash b/package/openresolv/openresolv.hash
new file mode 100644 (file)
index 0000000..e1a1fb5
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 96b3f84435a183426c622db7097a930fb0d48a99e82cd87ce83bd343b8c20574 openresolv-fe4e1ec4e2be2adfc1530ade94ebb30aa6f51540.tar.gz
+sha256 d1f9dcd2dac4e095b14caab517cfe791a6e0785346164b7d0cafc13c714f8aa5 LICENSE
diff --git a/package/openresolv/openresolv.mk b/package/openresolv/openresolv.mk
new file mode 100644 (file)
index 0000000..6adf973
--- /dev/null
@@ -0,0 +1,25 @@
+################################################################################
+#
+# openresolv
+#
+################################################################################
+
+OPENRESOLV_VERSION = fe4e1ec4e2be2adfc1530ade94ebb30aa6f51540
+OPENRESOLV_SITE = $(call github,rsmarples,openresolv,$(OPENRESOLV_VERSION))
+OPENRESOLV_LICENSE = BSD-2-Clause
+OPENRESOLV_LICENSE_FILES = LICENSE
+
+define OPENRESOLV_CONFIGURE_CMDS
+       cd $(@D) && $(TARGET_CONFIGURE_OPTS) ./configure --prefix=/usr \
+               --sysconfdir=/etc
+endef
+
+define OPENRESOLV_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
+endef
+
+define OPENRESOLV_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR="$(TARGET_DIR)" install
+endef
+
+$(eval $(generic-package))