cmake: bump version to 3.6.0
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Thu, 14 Jul 2016 10:06:50 +0000 (11:06 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 14 Jul 2016 10:23:14 +0000 (12:23 +0200)
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/cmake/0001-rename_cmake_rootfile.patch
package/cmake/cmake.hash
package/cmake/cmake.mk

index 915b7e32bb5b6559a7176e14129bd009b2f59625..3169f16850dc5dd24a7d50f4e59a30b3eb2709a5 100644 (file)
@@ -6,18 +6,23 @@ This buildroot-specific patch makes sure ctest looks also for
 "Modules/CMake.cmake.ctest" before complaining
 
 Signed-off-by: Davide Viti <zinosat@tiscali.it>
+[Vincent: tweak patch for 3.6.0]
+Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
 
---- cmake-3.0.2/Source/cmake.cxx~      2014-09-11 15:24:01.000000000 +0200
-+++ cmake-3.0.2/Source/cmake.cxx       2014-11-25 15:48:04.461033690 +0100
-@@ -957,7 +957,10 @@
-      "Path to cpack program executable.", cmCacheManager::INTERNAL);
+diff -rup a/Source/cmake.cxx b/Source/cmake.cxx
+--- a/Source/cmake.cxx 2016-07-07 15:47:27.000000000 +0100
++++ b/Source/cmake.cxx 2016-07-14 10:14:59.914265515 +0100
+@@ -771,7 +771,12 @@ int cmake::AddCMakePaths()
+                       "Path to cpack program executable.", cmState::INTERNAL);
  #endif
-   if(!cmSystemTools::FileExists(
--       (cmSystemTools::GetCMakeRoot()+"/Modules/CMake.cmake").c_str()))
-+       (cmSystemTools::GetCMakeRoot()+"/Modules/CMake.cmake").c_str()) &&
-+     !cmSystemTools::FileExists(
-+       (cmSystemTools::GetCMakeRoot()+"/Modules/CMake.cmake.ctest").c_str())
+   if (!cmSystemTools::FileExists(
+-        (cmSystemTools::GetCMakeRoot() + "/Modules/CMake.cmake").c_str())) {
++        (cmSystemTools::GetCMakeRoot() + "/Modules/CMake.cmake").c_str()) &&
++      !cmSystemTools::FileExists(
++        (cmSystemTools::GetCMakeRoot()+"/Modules/CMake.cmake.ctest").c_str()
++        )
 +     )
-     {
++  {
      // couldn't find modules
-     cmSystemTools::Error("Could not find CMAKE_ROOT !!!\n"
+     cmSystemTools::Error(
+       "Could not find CMAKE_ROOT !!!\n"
index e40d4ea39ace62fc9b0d05ee4f0a6e431e5d640d..7cd1133289ed81241251c15ad1d25fa04a4417d5 100644 (file)
@@ -1,2 +1,2 @@
-# From http://www.cmake.org/files/v3.5/cmake-3.5.2-SHA-256.txt
-sha256 92d8410d3d981bb881dfff2aed466da55a58d34c7390d50449aa59b32bb5e62a        cmake-3.5.2.tar.gz
+# From http://www.cmake.org/files/v3.6/cmake-3.6.0-SHA-256.txt
+sha256 fd05ed40cc40ef9ef99fac7b0ece2e0b871858a82feade48546f5d2940147670  cmake-3.6.0.tar.gz
index 7a80c1bfefcad4dfcb0b85db79d6dce804a878d9..25eafe8cf4b07ef0c70ec02096ed47e2cd2abd97 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-CMAKE_VERSION_MAJOR = 3.5
-CMAKE_VERSION = $(CMAKE_VERSION_MAJOR).2
+CMAKE_VERSION_MAJOR = 3.6
+CMAKE_VERSION = $(CMAKE_VERSION_MAJOR).0
 CMAKE_SITE = https://cmake.org/files/v$(CMAKE_VERSION_MAJOR)
 CMAKE_LICENSE = BSD-3c
 CMAKE_LICENSE_FILES = Copyright.txt