package/webkitgtk: fix gstreamer-gl dependency
authorJames Hilliard <james.hilliard1@gmail.com>
Wed, 7 Aug 2019 19:23:13 +0000 (13:23 -0600)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 5 Feb 2020 15:26:29 +0000 (16:26 +0100)
The gstreamer1 opengl plugin was moved from gst1-plugins-bad to
gst1-plugins-base so we need to update webkitgtk to depend on the
correct package.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Reviewed-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/webkitgtk/Config.in
package/webkitgtk/webkitgtk.mk

index 3ac76f988601d0de1484099c3bed49aeb9597888..4f10466c1f682144c9fe7b5f594b19f4fbb02f4d 100644 (file)
@@ -108,8 +108,7 @@ if BR2_PACKAGE_WEBKITGTK_MULTIMEDIA
 config BR2_PACKAGE_WEBKITGTK_USE_GSTREAMER_GL
        bool "use gstreamer-gl"
        default y
-       depends on BR2_PACKAGE_GST1_PLUGINS_BASE_HAS_LIB_OPENGL
-       select BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_GL
+       depends on BR2_PACKAGE_GST1_PLUGINS_BASE_LIB_OPENGL_OPENGL
        help
          Use the GStreamer GL elements for handling video content.
          This is recommended as it improves performance of video
index 389c16de4a9feab98a14eff8d22eaf570a6a0e7e..e5d591fcd2216eec45a154c756f3c74a5b4c227a 100644 (file)
@@ -100,7 +100,6 @@ endif
 
 ifeq ($(BR2_PACKAGE_WEBKITGTK_USE_GSTREAMER_GL),y)
 WEBKITGTK_CONF_OPTS += -DUSE_GSTREAMER_GL=ON
-WEBKITGTK_DEPENDENCIES += gst1-plugins-bad
 else
 WEBKITGTK_CONF_OPTS += -DUSE_GSTREAMER_GL=OFF
 endif