postgresql: disable rpath
authorBaruch Siach <baruch@tkos.co.il>
Tue, 29 Sep 2015 20:01:31 +0000 (23:01 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 29 Sep 2015 22:32:04 +0000 (00:32 +0200)
The linker -rpath option causes the linker to search for libraries in host
directories.

Should fix:
http://autobuild.buildroot.net/results/2cc/2cca5f8d8a8cd1bf9bbbc8c955aec477839e059f/
http://autobuild.buildroot.net/results/da6/da61d30791f216033971d679c84704d0fc0c3de0/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/postgresql/postgresql.mk

index 382f3209ee22c5b27237d13bb8b496d3788c04f6..2bad6b4d0547b59c01ff2db22cac73218cf5a00f 100644 (file)
@@ -15,6 +15,7 @@ POSTGRESQL_CONF_ENV = ac_cv_type_struct_sockaddr_in6=yes \
                      pgac_cv_snprintf_long_long_int_format="%lld" \
                      pgac_cv_snprintf_size_t_support=yes
 POSTGRESQL_AUTORECONF = YES
+POSTGRESQL_CONF_OPTS = --disable-rpath
 
 ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
 # PostgreSQL does not build against uClibc with locales