python-versiontools: new package
authorLudovic Desroches <ludovic.desroches@atmel.com>
Wed, 11 Dec 2013 20:27:02 +0000 (21:27 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 15 Dec 2013 12:41:32 +0000 (13:41 +0100)
[Thomas: convert to the Python package infrastructure, added license
informations.]

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Config.in
package/python-versiontools/Config.in [new file with mode: 0644]
package/python-versiontools/python-versiontools.mk [new file with mode: 0644]

index 3316d0fe6eed9f044506a145b8e5966e0a7ddefa..b766939be4117c1b89e032917560abbcdfd3d9d8 100644 (file)
@@ -406,6 +406,7 @@ source "package/python-pyzmq/Config.in"
 source "package/python-serial/Config.in"
 source "package/python-setuptools/Config.in"
 source "package/python-thrift/Config.in"
+source "package/python-versiontools/Config.in"
 endmenu
 endif
 source "package/python3/Config.in"
diff --git a/package/python-versiontools/Config.in b/package/python-versiontools/Config.in
new file mode 100644 (file)
index 0000000..cb260c1
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_VERSIONTOOLS
+       bool "python-versiontools"
+       depends on BR2_PACKAGE_PYTHON
+       help
+         Smart replacement for plain tuple used in __version__.
+
+         https://pypi.python.org/pypi/versiontools
diff --git a/package/python-versiontools/python-versiontools.mk b/package/python-versiontools/python-versiontools.mk
new file mode 100644 (file)
index 0000000..7d745b9
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-versiontools
+#
+################################################################################
+
+PYTHON_VERSIONTOOLS_VERSION = 1.9.1
+PYTHON_VERSIONTOOLS_SOURCE = versiontools-$(PYTHON_VERSIONTOOLS_VERSION).tar.gz
+PYTHON_VERSIONTOOLS_SITE = http://pypi.python.org/packages/source/v/versiontools/
+PYTHON_VERSIONTOOLS_SETUP_TYPE = setuptools
+PYTHON_VERSIONTOOLS_LICENSE = LGPLv3
+
+$(eval $(python-package))