ruby: explicitly disable SSP support
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 9 Nov 2015 20:25:11 +0000 (21:25 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 10 Nov 2015 10:28:03 +0000 (11:28 +0100)
The SSP support checks of the Ruby configure script do not do a full
link, and therefore don't properly detect if SSP support is fully
functional or not, which causes some build failures if the compiler
supports -fstack-protector but the C library does not provide the SSP
implementation.

To avoid this, we explicitly tell ruby if SSP support is available or
not.

Fixes:

  http://autobuild.buildroot.net/results/001/00154b0142f51c197d5d53ae36f7adc4f8250d9d/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ruby/ruby.mk

index 298493c0f1df806385e6eaeef4cb970f5955eae2..17104b6d85fdfba2b6cd7bcf369caaa09654c076 100644 (file)
@@ -36,6 +36,10 @@ RUBY_CONF_ENV += ac_cv_func_dl_iterate_phdr=no
 RUBY_CONF_OPTS += --with-out-ext=fiddle
 endif
 
+ifeq ($(BR2_TOOLCHAIN_HAS_SSP),)
+RUBY_CONF_ENV += stack_protector=no
+endif
+
 # Force optionals to build before we do
 ifeq ($(BR2_PACKAGE_BERKELEYDB),y)
 RUBY_DEPENDENCIES += berkeleydb