toolchain/binutils: make sure target-binutils runs after busybox
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 22 Nov 2009 20:25:31 +0000 (21:25 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 22 Nov 2009 20:25:31 +0000 (21:25 +0100)
Closes #597

Ensure that binutils-target runs after busybox if enabled, so it can
overwrite the busybox symlink for ar if that applet is enabled.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
toolchain/binutils/binutils.mk

diff --git a/CHANGES b/CHANGES
index abf9774fa54ca6f2a1cf5ea73fd024b92b5fe92a..e6c11064247bf7c0b783784c9711714f9240e02a 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -18,8 +18,8 @@
        ncftp, ncurses, netkittelnet, netsnmp, ntfs-3g, openntp, openssl, php,
        python, quagga, radvd, rsync, samba, sawman, sdl, shared-mime-info,
        spawn-fcgi, speech-tools, sqlite, squashfs, synergy, syslinux,
-       tcpdump, u-boot, util-linux, valgrind, vsftpd, wipe, wpa-supplicant,
-       xdata_xcursor-themes, zlib
+       target-binutils, tcpdump, u-boot, util-linux, valgrind, vsftpd, wipe,
+       wpa-supplicant, xdata_xcursor-themes, zlib
 
        Removed package: mdnsresponder, mpatrol, gcc 3.4.6 + 4.0.4
 
@@ -34,6 +34,7 @@
        #565: libevent: Bump version and clean up makefile
        #587: Use iptables multipurpose binaries and bump to 1.4.4
        #593: Missing early check for patch(1)
+       #597: (REOP)  Selecting busybox in buildroot's config clobbers ar ...
        #609: libmicrohttpd: New package
        #615: python: Don't delete .py files unless asked
        #617: netkit/inetd requires RPC and fails to build if RPC is disabled
index f3509e7102ad342e2bf0a5660d4a9a66f6d168c4..04122b38531e009f0a568de42e414609a939b8c0 100644 (file)
@@ -175,6 +175,13 @@ endif
        -$(STRIPCMD) $(TARGET_DIR)/usr/$(REAL_GNU_TARGET_NAME)/bin/* > /dev/null 2>&1
        -$(STRIPCMD) $(TARGET_DIR)/usr/bin/* > /dev/null 2>&1
 
+# If both binutils-target and busybox are selected, make certain binutils
+# gets to run after busybox, so it can overwrite the busybox symlink for
+# ar if enabled
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+BINUTILS_TARGET_PREREQ += busybox
+endif
+
 binutils_target: $(BINUTILS_TARGET_PREREQ) $(TARGET_DIR)/usr/bin/ld
 
 binutils_target-clean: