package/gupnp-av: add optional dependency for gobject-introspection
authorAdam Duskett <Aduskett@gmail.com>
Sun, 15 Mar 2020 17:24:58 +0000 (10:24 -0700)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 22 Mar 2020 10:40:36 +0000 (11:40 +0100)
If gobject-introspection is selected, explicitly set --enable-introspection in
the configure options and add a dependency for gobject-introspection.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/gupnp-av/gupnp-av.mk

index c670ab6d43f7e9e1ce3b4ab31c0fdbe476a5287a..55436d0e53e0e84a34bf283c63e71a932bb270d3 100644 (file)
@@ -13,4 +13,11 @@ GUPNP_AV_LICENSE_FILES = COPYING
 GUPNP_AV_INSTALL_STAGING = YES
 GUPNP_AV_DEPENDENCIES = host-pkgconf libglib2 libxml2 gupnp
 
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+GUPNP_AV_CONF_OPTS += --enable-introspection
+GUPNP_AV_DEPENDENCIES += gobject-introspection
+else
+GUPNP_AV_CONF_OPTS += --disable-introspection
+endif
+
 $(eval $(autotools-package))