package/hiredis: install alloc.h
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 29 Mar 2020 08:36:50 +0000 (10:36 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 29 Mar 2020 14:32:51 +0000 (16:32 +0200)
This will fix build of collectd, proftpd ... with latest hiredis

Fixes:
 - http://autobuild.buildroot.org/results/f5afe60defd63461a5fc06b26bd4759fb5f56a8f
 - http://autobuild.buildroot.org/results/45e980c85d170827d3a41e7443cf1088b2d59ead

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/hiredis/hiredis.mk

index 02055b05d43281cbc71da48a7d8a141d2e8035c7..230fb2d187d716b5cbf22aa8a1b626ced5b0a7a5 100644 (file)
@@ -55,7 +55,7 @@ endif
 define HIREDIS_INSTALL_STAGING_CMDS
        mkdir -p $(HIREDIS_INCLUDE_DIR)
        cp -dpfr $(@D)/hiredis.h $(@D)/async.h $(@D)/read.h $(@D)/sds.h \
-               $(@D)/adapters $(HIREDIS_INCLUDE_DIR)
+               $(@D)/alloc.h $(@D)/adapters $(HIREDIS_INCLUDE_DIR)
        $(INSTALL) -D -m 0644 $(@D)/hiredis.pc \
                $(STAGING_DIR)/usr/lib/pkgconfig/hiredis.pc
        $(HIREDIS_INSTALL_STAGING_STATIC_LIB)