uclibc: clean-up test suite build command
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>
Mon, 20 Apr 2015 09:10:18 +0000 (12:10 +0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 18 Oct 2015 21:39:27 +0000 (23:39 +0200)
Starting from uClibc 0.9.32 "test_compile" target builds tests flawlessly.
For 0.9.31 it lead to build failure, but now when AVR32 support was dropped
I think this change worth applying.

Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Cc: Peter Korsgaard <peter@korsgaard.com>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/uclibc/uclibc.mk

index eaac9dc4033f24b496c0fc3105c75f1638799a2d..7ff98b0fdce9eb96f79a07adeb48915ae19331a0 100644 (file)
@@ -398,12 +398,10 @@ endef
 
 ifeq ($(BR2_UCLIBC_INSTALL_TEST_SUITE),y)
 define UCLIBC_BUILD_TEST_SUITE
-       $(MAKE1) -C $(@D)/test \
+       $(MAKE1) -C $(@D) \
                $(UCLIBC_MAKE_FLAGS) \
-               ARCH_CFLAGS=-I$(STAGING_DIR)/usr/include \
                UCLIBC_ONLY=1 \
-               TEST_INSTALLED_UCLIBC=1 \
-               compile
+               test_compile
 endef
 endif