package/tcpdump: remove duplicated binary
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Tue, 16 Feb 2021 12:50:30 +0000 (13:50 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 16 Feb 2021 19:43:53 +0000 (20:43 +0100)
Since tcpdump 4.99.0, the 'tcpdump' binary is no longer installed in
/usr/sbin but in /usr/bin. This change invalidates the Buildroot hook
'TCPDUMP_REMOVE_DUPLICATED_BINARY', causing a fairly large rootfs size
increase as a result.

Update the path inside this hook.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tcpdump/tcpdump.mk

index f8ea6576eefb3a12cad87637aced0575f7b8eca4..c562034a4e7c4026a4556d749eb79ef9775911c0 100644 (file)
@@ -22,7 +22,7 @@ TCPDUMP_SELINUX_MODULES = netutils
 
 # make install installs an unneeded extra copy of the tcpdump binary
 define TCPDUMP_REMOVE_DUPLICATED_BINARY
-       rm -f $(TARGET_DIR)/usr/sbin/tcpdump.$(TCPDUMP_VERSION)
+       rm -f $(TARGET_DIR)/usr/bin/tcpdump.$(TCPDUMP_VERSION)
 endef
 
 TCPDUMP_POST_INSTALL_TARGET_HOOKS += TCPDUMP_REMOVE_DUPLICATED_BINARY