.gitlab-ci.yml: extend check-package test to Config.* files
authorRicardo Martincoski <ricardo.martincoski@gmail.com>
Sun, 1 Apr 2018 05:08:50 +0000 (02:08 -0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 1 Apr 2018 08:16:35 +0000 (10:16 +0200)
Now that all issues in Config.in files have been fixed, let's try to
make sure we don't introduce new ones by checking regularly these files
issues in Gitlab CI.

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
.gitlab-ci.yml
.gitlab-ci.yml.in

index fd1aeb3408d7cbd8fd11b8c50994c7ca0ec26cb2..fcb53d64516374a3b271b7763995c9c903a4c163 100644 (file)
@@ -43,7 +43,8 @@ check-flake8:
 
 check-package:
     script:
-        - find . -type f \( -name '*.mk' -o -name '*.hash' \) -exec ./utils/check-package {} +
+        - find . -type f \( -name '*.mk' -o -name '*.hash' -o -name 'Config.*' \)
+            -exec ./utils/check-package {} +
 
 .defconfig: &defconfig
     # Running the defconfigs for every push is too much, so limit to
index bffcb02be1ef3ca0b25503663f281de1dbf7efb9..fb2650c5ceee1711e32f549666782a0846c84fff 100644 (file)
@@ -43,7 +43,8 @@ check-flake8:
 
 check-package:
     script:
-        - find . -type f \( -name '*.mk' -o -name '*.hash' \) -exec ./utils/check-package {} +
+        - find . -type f \( -name '*.mk' -o -name '*.hash' -o -name 'Config.*' \)
+            -exec ./utils/check-package {} +
 
 .defconfig: &defconfig
     # Running the defconfigs for every push is too much, so limit to