kexec: fix compilation with gcc 4.6
authorSven Neumann <s.neumann@raumfeld.com>
Mon, 26 Sep 2011 12:31:17 +0000 (14:31 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 26 Sep 2011 20:16:08 +0000 (22:16 +0200)
gcc 4.6 has stricter checks for invalid command-line options.
Fix compilation by passing linker options with -Wl,

Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/kexec/kexec-fix-linker-options.patch [new file with mode: 0644]

diff --git a/package/kexec/kexec-fix-linker-options.patch b/package/kexec/kexec-fix-linker-options.patch
new file mode 100644 (file)
index 0000000..7bd5f1d
--- /dev/null
@@ -0,0 +1,15 @@
+Fix compilation with gcc 4.6 by correcting the way that linker options
+are passed to gcc.
+
+Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
+--- kexec-2.0.2/purgatory/Makefile.orig        2011-09-26 14:16:44.256595912 +0200
++++ kexec-2.0.2/purgatory/Makefile     2011-09-26 14:17:01.606621357 +0200
+@@ -56,7 +56,7 @@
+                       -I$(srcdir)/include \
+                       -I$(shell $(CC) -print-file-name=include)
+ $(PURGATORY): LDFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS)\
+-                      --no-undefined -nostartfiles -nostdlib -nodefaultlibs \
++                      -Wl,-no-undefined -nostartfiles -nostdlib -nodefaultlibs \
+                       -e purgatory_start -r
+ $(PURGATORY): $(PURGATORY_OBJS)