conntrack-tools: new package
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 4 May 2012 03:16:46 +0000 (03:16 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 6 May 2012 21:13:46 +0000 (23:13 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/conntrack-tools/Config.in [new file with mode: 0644]
package/conntrack-tools/conntrack-tools.mk [new file with mode: 0644]

index aecb056c95e1c6062c0dff287bbb733c14eb711a..34c0280d8b9baa3f0d8e475fc79910dc4e55aef0 100644 (file)
@@ -490,6 +490,7 @@ source "package/can-utils/Config.in"
 source "package/connman/Config.in"
 source "package/ctorrent/Config.in"
 source "package/cifs-utils/Config.in"
+source "package/conntrack-tools/Config.in"
 source "package/cups/Config.in"
 if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
 source "package/dhcp/Config.in"
diff --git a/package/conntrack-tools/Config.in b/package/conntrack-tools/Config.in
new file mode 100644 (file)
index 0000000..12eb988
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_CONNTRACK_TOOLS
+       bool "conntrack-tools"
+       depends on BR2_INET_IPV6
+       select BR2_PACKAGE_LIBNETFILTER_CONNTRACK
+       help
+         The conntrack-tools are a set of tools targeted at
+         system administrators.
+         They are conntrack, the userspace command line interface,
+         and conntrackd, the userspace daemon.
+
+         http://www.netfilter.org/projects/conntrack-tools/
+
+comment "conntrack-tools requires a toolchain with IPV6 support"
+       depends on !BR2_INET_IPV6
diff --git a/package/conntrack-tools/conntrack-tools.mk b/package/conntrack-tools/conntrack-tools.mk
new file mode 100644 (file)
index 0000000..8b41127
--- /dev/null
@@ -0,0 +1,12 @@
+#############################################################
+#
+# conntrack-tools
+#
+#############################################################
+
+CONNTRACK_TOOLS_VERSION = 1.0.1
+CONNTRACK_TOOLS_SOURCE = conntrack-tools-$(CONNTRACK_TOOLS_VERSION).tar.bz2
+CONNTRACK_TOOLS_SITE = http://www.netfilter.org/projects/conntrack-tools/files
+CONNTRACK_TOOLS_DEPENDENCIES = host-pkg-config libnetfilter_conntrack
+
+$(eval $(call AUTOTARGETS))