motion: fix config file location
authorChristopher McCrory <chrismcc@gmail.com>
Thu, 8 Mar 2018 14:15:36 +0000 (06:15 -0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 1 Apr 2018 20:08:14 +0000 (22:08 +0200)
Install the motion.config file were the program expects it to be. From
the motion source code:

snprintf(filename, PATH_MAX, "%s/motion/motion.conf", sysconfdir);

Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/motion/motion.mk

index 2ba16fc837d1938fa36c9222dff07c7c08f6f89a..0f4898674b01b1646eccabdf7cc9ec0646a8c3ce 100644 (file)
@@ -59,7 +59,7 @@ endif
 # directories: docs, examples and init scripts
 define MOTION_INSTALL_TARGET_CMDS
        $(INSTALL) -D -m 0644 $(@D)/motion-dist.conf \
-               $(TARGET_DIR)/etc/motion.conf
+               $(TARGET_DIR)/etc/motion/motion.conf
        $(INSTALL) -D -m 0755 $(@D)/motion $(TARGET_DIR)/usr/bin/motion
 endef