Revert "package/dtc: bump to v1.5.1"
authorPeter Korsgaard <peter@korsgaard.com>
Tue, 5 Nov 2019 21:15:49 +0000 (22:15 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 5 Nov 2019 21:15:49 +0000 (22:15 +0100)
This reverts commit 1e55b66e975d234f5bff992785762e8f7ee5f5b9.

This bump breaks the build of a number of defconfigs with errors like:

HOSTCC  scripts/dtc/libfdt/fdt_ro.o
scripts/dtc/libfdt/fdt_ro.c:92:10: error: redefinition of ‘fdt_get_max_phandle’
uint32_t fdt_get_max_phandle(const void *fdt)
^~~~~~~~~~~~~~~~~~~
In file included from scripts/dtc/libfdt/fdt_ro.c:54:
/work/beaglebone/host/include/libfdt.h:384:24: note: previous definition of ‘fdt_get_max_phandle’ was here

So revert it for 2019.11.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/dtc/0001-Fix-include-guards-for-older-kernel-u-boot-sources.patch
package/dtc/0002-Makefile-Add-EXTRA_CFLAGS-variable.patch [new file with mode: 0644]
package/dtc/dtc.hash
package/dtc/dtc.mk

index bf3d61a8ce0feb47c8441e270438ad225ea337c0..bff5f4c07afe458144750f8cc74effc56ad2988a 100644 (file)
@@ -15,8 +15,6 @@ Signed-off-by: Lothar Felten <lothar.felten@gmail.com>
 [ThomasDS: also update fdt.h which has the same issue, seen on U-Boot
 2011.03]
 Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
-[Titouan: Taking new SPDX line into account]
-Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
 ---
  libfdt/fdt.h        | 4 ++++
  libfdt/libfdt.h     | 4 ++++
@@ -27,8 +25,7 @@ diff --git a/libfdt/fdt.h b/libfdt/fdt.h
 index 74961f9..2904f48 100644
 --- a/libfdt/fdt.h
 +++ b/libfdt/fdt.h
-@@ -1,4 +1,8 @@
- /* SPDX-License-Identifier: (GPL-2.0-or-later OR BSD-2-Clause) */
+@@ -1,3 +1,7 @@
 +#ifdef _FDT_H
 +#warning "Please consider updating your kernel and/or u-boot version"
 +#define FDT_H
@@ -40,8 +37,7 @@ diff --git a/libfdt/libfdt.h b/libfdt/libfdt.h
 index 830b77e..bef4566 100644
 --- a/libfdt/libfdt.h
 +++ b/libfdt/libfdt.h
-@@ -1,4 +1,8 @@
- /* SPDX-License-Identifier: (GPL-2.0-or-later OR BSD-2-Clause) */
+@@ -1,3 +1,7 @@
 +#ifdef _LIBFDT_H
 +#warning "Please consider updating your kernel and/or u-boot version"
 +#define LIBFDT_H
@@ -53,8 +49,7 @@ diff --git a/libfdt/libfdt_env.h b/libfdt/libfdt_env.h
 index eb20538..6a61e6a 100644
 --- a/libfdt/libfdt_env.h
 +++ b/libfdt/libfdt_env.h
-@@ -1,4 +1,8 @@
- /* SPDX-License-Identifier: (GPL-2.0-or-later OR BSD-2-Clause) */
+@@ -1,3 +1,7 @@
 +#ifdef _LIBFDT_ENV_H
 +#warning "Please consider updating your kernel and/or u-boot version"
 +#define LIBFDT_ENV_H
@@ -63,5 +58,5 @@ index eb20538..6a61e6a 100644
  #define LIBFDT_ENV_H
  /*
 -- 
-2.21.0
+2.19.2
 
diff --git a/package/dtc/0002-Makefile-Add-EXTRA_CFLAGS-variable.patch b/package/dtc/0002-Makefile-Add-EXTRA_CFLAGS-variable.patch
new file mode 100644 (file)
index 0000000..b3f14a6
--- /dev/null
@@ -0,0 +1,37 @@
+From f7c659d7daff5dbf4a0be959a544f15eab7fc49c Mon Sep 17 00:00:00 2001
+From: Joel Stanley <joel@jms.id.au>
+Date: Mon, 22 Jul 2019 12:21:49 +0930
+Subject: [PATCH] Makefile: Add EXTRA_CFLAGS variable
+
+Distributions packaging dtc may need to set extra flags. Currently when
+they do that it overrides the ones set by the makefile. This is
+particularly problematic when compiling without yaml, as the yaml
+detection is ignored.
+
+ ld: dtc.o: in function `main':
+ dtc.c:(.text.startup+0x718): undefined reference to `dt_to_yaml'
+
+This patch provides a EXTRA_CFLAGS variable that is added to the list of
+CFLAGS, and can be set on the command line when packaging.
+
+Signed-off-by: Joel Stanley <joel@jms.id.au>
+---
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index e6b32cf1cbf5..6807669569b3 100644
+--- a/Makefile
++++ b/Makefile
+@@ -18,7 +18,7 @@ CONFIG_LOCALVERSION =
+ CPPFLAGS = -I libfdt -I .
+ WARNINGS = -Wall -Wpointer-arith -Wcast-qual -Wnested-externs \
+       -Wstrict-prototypes -Wmissing-prototypes -Wredundant-decls -Wshadow
+-CFLAGS = -g -Os $(SHAREDLIB_CFLAGS) -Werror $(WARNINGS)
++CFLAGS = -g -Os $(SHAREDLIB_CFLAGS) -Werror $(WARNINGS) $(EXTRA_CFLAGS)
+ BISON = bison
+ LEX = flex
+-- 
+2.20.1
+
index 3adfcc45a9621d125a99514d3a05968c42ee8039..4d0aaea6017aed3ae18eb75e275d4e2289a7b0a7 100644 (file)
@@ -1,5 +1,5 @@
 # from https://www.kernel.org/pub/software/utils/dtc/sha256sums.asc
-sha256 660b74039690fc37013660544d09191834efb58503c73c555c5513ba75ab031f  dtc-1.5.1.tar.xz
+sha256 c672e443c9f7e39f5a7c8e602da6777f9ad55ad70de87de300a43828c8050172  dtc-1.5.0.tar.xz
 
 # Hash for license files
 sha256 171ce1c292cf148a5be9ff95ce7e5c3d79a002721ab8e119eae3c0f5336d2b3d  README.license
index 7587638016eda362cc2d9c844941eebe846d7eea..a0fffa5b807b8cb7408c37d4c9f2e882ece2777e 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-DTC_VERSION = 1.5.1
+DTC_VERSION = 1.5.0
 DTC_SOURCE = dtc-$(DTC_VERSION).tar.xz
 DTC_SITE = https://www.kernel.org/pub/software/utils/dtc
 DTC_LICENSE = GPL-2.0+ or BSD-2-Clause (library)