libmemcached: disable sanitizer
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 13 Nov 2014 11:11:57 +0000 (08:11 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 13 Nov 2014 15:25:07 +0000 (16:25 +0100)
The tests are flawed and we don't generally enable a dozen hardening
CFLAGS automatically. Fixes:
http://autobuild.buildroot.net/results/a84/a84ab4f0fdea6bbab971ba379e3066cddb25bfaa/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libmemcached/0001-disable-tests.patch [new file with mode: 0644]
package/libmemcached/0002-disable-sanitizer.patch [new file with mode: 0644]
package/libmemcached/libmemcached-01-disable-tests.patch [deleted file]
package/libmemcached/libmemcached.mk

diff --git a/package/libmemcached/0001-disable-tests.patch b/package/libmemcached/0001-disable-tests.patch
new file mode 100644 (file)
index 0000000..6128306
--- /dev/null
@@ -0,0 +1,42 @@
+Disable the tests, cuts build time by half and avoids build issues
+with extra dependencies.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura libmemcached-1.0.18.orig/Makefile.am libmemcached-1.0.18/Makefile.am
+--- libmemcached-1.0.18.orig/Makefile.am       2014-07-19 09:24:45.246418899 -0300
++++ libmemcached-1.0.18/Makefile.am    2014-07-19 09:25:12.701349345 -0300
+@@ -1,6 +1,6 @@
+ # vim:ft=automake
+-ACLOCAL_AMFLAGS= -I m4 -I libtest/m4
++ACLOCAL_AMFLAGS= -I m4
+ AM_YFLAGS= -d
+ # includes append to these:
+@@ -45,8 +45,6 @@
+ include libmemcached-1.0/include.am
+ else
+-include libtest/include.am
+-
+ include libhashkit-1.0/include.am
+ include libmemcached-1.0/include.am
+@@ -76,7 +74,6 @@
+ include libmemcachedinternal/util/include.am
+ include rpm/include.mk
+ include support/include.am
+-include tests/include.am
+ include util/include.am
+ include win32/include.am
+@@ -103,7 +100,7 @@
+       @echo "Files that need to be either removed or checked in:"
+       @bzr unknowns
+-clean-local: clean-libtest-check clean-docs-check clean-rpm
++clean-local: clean-docs-check clean-rpm
+ lcov: lcov-clean check
diff --git a/package/libmemcached/0002-disable-sanitizer.patch b/package/libmemcached/0002-disable-sanitizer.patch
new file mode 100644 (file)
index 0000000..108da22
--- /dev/null
@@ -0,0 +1,25 @@
+Disable sanitizer checks, they're busted.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+
+diff -Nura libmemcached-1.0.18.orig/m4/ax_harden_compiler_flags.m4 libmemcached-1.0.18/m4/ax_harden_compiler_flags.m4
+--- libmemcached-1.0.18.orig/m4/ax_harden_compiler_flags.m4    2014-11-13 08:07:09.011614311 -0300
++++ libmemcached-1.0.18/m4/ax_harden_compiler_flags.m4 2014-11-13 08:07:52.406092440 -0300
+@@ -222,8 +222,6 @@
+ #         GCC 4.5 removed this.
+ #         _APPEND_COMPILE_FLAGS_ERROR([-Wunreachable-code])
+-          _SET_SANITIZE_FLAGS
+-
+           AS_IF([test "x$ax_enable_debug" = xno],
+             [AS_IF([test "x$ac_cv_vcs_checkout" = xyes],
+               [AS_IF([test "x${host_os}" != "xmingw"],
+@@ -337,8 +335,6 @@
+                 _APPEND_COMPILE_FLAGS_ERROR([-fstack-protector-all])
+                 ])])])])
+-          _SET_SANITIZE_FLAGS
+-
+           AS_IF([test "x$ac_cv_warnings_as_errors" = xyes],
+                 [AX_APPEND_FLAG([-Werror])])
+           AC_LANG_POP([C++])
diff --git a/package/libmemcached/libmemcached-01-disable-tests.patch b/package/libmemcached/libmemcached-01-disable-tests.patch
deleted file mode 100644 (file)
index 6128306..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-Disable the tests, cuts build time by half and avoids build issues
-with extra dependencies.
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
-diff -Nura libmemcached-1.0.18.orig/Makefile.am libmemcached-1.0.18/Makefile.am
---- libmemcached-1.0.18.orig/Makefile.am       2014-07-19 09:24:45.246418899 -0300
-+++ libmemcached-1.0.18/Makefile.am    2014-07-19 09:25:12.701349345 -0300
-@@ -1,6 +1,6 @@
- # vim:ft=automake
--ACLOCAL_AMFLAGS= -I m4 -I libtest/m4
-+ACLOCAL_AMFLAGS= -I m4
- AM_YFLAGS= -d
- # includes append to these:
-@@ -45,8 +45,6 @@
- include libmemcached-1.0/include.am
- else
--include libtest/include.am
--
- include libhashkit-1.0/include.am
- include libmemcached-1.0/include.am
-@@ -76,7 +74,6 @@
- include libmemcachedinternal/util/include.am
- include rpm/include.mk
- include support/include.am
--include tests/include.am
- include util/include.am
- include win32/include.am
-@@ -103,7 +100,7 @@
-       @echo "Files that need to be either removed or checked in:"
-       @bzr unknowns
--clean-local: clean-libtest-check clean-docs-check clean-rpm
-+clean-local: clean-docs-check clean-rpm
- lcov: lcov-clean check
index daeb2832e2ef8a477c03e4c48aa6d364b46a474e..d442b3c16e7925754368294b33ddb7ca38bc7cce 100644 (file)
@@ -13,7 +13,7 @@ LIBMEMCACHED_CONF_ENV = ac_cv_prog_cc_c99='-std=gnu99' \
 LIBMEMCACHED_CONF_OPTS = --disable-dtrace
 LIBMEMCACHED_INSTALL_STAGING = YES
 LIBMEMCACHED_DEPENDENCIES = $(if $(BR2_PACKAGE_LIBEVENT),libevent)
-# For libmemcached-01-disable-tests.patch
+# For 0001-disable-tests.patch and 0002-disable-sanitizer.patch
 LIBMEMCACHED_AUTORECONF = YES
 LIBMEMCACHED_LICENSE = BSD-3c
 LIBMEMCACHED_LICENSE_FILES = COPYING