bump json-c to 0.10
authorAndreas Wetzel <andreas.wetzel@nanotronic.ch>
Tue, 19 Feb 2013 02:07:33 +0000 (02:07 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 25 Feb 2013 20:48:36 +0000 (21:48 +0100)
this patch bumps json-c to version 0.10 and adapts the no-reentrant patch
to the new version.

Signed-off-by: Andreas Wetzel <andreas.wetzel@nanotronic.ch>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/json-c/json-c-no-reentrant.patch
package/json-c/json-c.mk

index a01181cfbb464927db6b24720b947c5829800737..31343c0a83f11206ac45a14a3dc142b96f8f6c35 100644 (file)
@@ -8,26 +8,24 @@ patch to avoid having to autoreconfigure the package.
 
 Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
 
-Index: b/Makefile.am
+Index: b/Makefile.am.inc
 ===================================================================
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1,4 +1,4 @@
+--- a/Makefile.am.inc
++++ b/Makefile.am.inc
+@@ -1,2 +1,2 @@
 -AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
 +AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE
  
- EXTRA_DIST = README.html README-WIN32.html config.h.win32 doc
 Index: b/Makefile.in
 ===================================================================
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -219,7 +219,7 @@
+@@ -263,7 +263,7 @@
  top_build_prefix = @top_build_prefix@
  top_builddir = @top_builddir@
  top_srcdir = @top_srcdir@
 -AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE -D_REENTRANT
 +AM_CFLAGS = -Wall -Wwrite-strings -Werror -std=gnu99 -D_GNU_SOURCE
- EXTRA_DIST = README.html README-WIN32.html config.h.win32 doc
+ EXTRA_DIST = README.html README-WIN32.html config.h.win32 doc json-c.vcproj
+ SUBDIRS = . tests
  lib_LTLIBRARIES = libjson.la
- pkgconfigdir = $(libdir)/pkgconfig
index ed4a6d0a70a823bec1b37c4a53ee40713f0a9541..a0b5cae5a98c9302fe5def1d3c8d7d7384e9af88 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-JSON_C_VERSION = 0.9
-JSON_C_SITE = http://oss.metaparadigm.com/json-c/
+JSON_C_VERSION = 0.10
+JSON_C_SITE = https://github.com/downloads/json-c/json-c
 JSON_C_INSTALL_STAGING = YES
 
 $(eval $(autotools-package))