linux: restore DEPMOD usage
authorMike Frysinger <vapier@gentoo.org>
Wed, 8 Dec 2010 09:27:06 +0000 (04:27 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 11 Dec 2010 21:57:07 +0000 (22:57 +0100)
The linux.mk rewrite lost the DEPMOD setting while installing modules
which means depending on host-module-init-tools has been useless.
Instead, the build system has been executing /sbin/depmod.

While we're here, drop the INSTALL_MOD_PATH since LINUX26_MAKE_FLAGS
already contains it.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/linux.mk

index 5f89b7dd33e18bf25bbbfd39df1ffcd2ef131ca2..e9c37ebc7d5a2bdcd0cb0e213ae908c1e2d722ae 100644 (file)
@@ -132,7 +132,7 @@ $(LINUX26_DIR)/.stamp_installed: $(LINUX26_DIR)/.stamp_compiled
        # directories, not relevant on the target
        @if [ $(shell grep -c "CONFIG_MODULES=y" $(LINUX26_DIR)/.config) != 0 ] ; then  \
                $(TARGET_MAKE_ENV) $(MAKE1) $(LINUX26_MAKE_FLAGS) -C $(@D)              \
-                       INSTALL_MOD_PATH=$(TARGET_DIR) modules_install ;                \
+                       DEPMOD="$(HOST_DIR)/usr/sbin/depmod" modules_install ;          \
                rm -f $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION_PROBED)/build ;       \
                rm -f $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION_PROBED)/source ;      \
        fi