package/libkrb5: add openssl optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 13 Jun 2021 09:10:43 +0000 (11:10 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 13 Jun 2021 15:28:00 +0000 (17:28 +0200)
openssl is an optional dependency which is enabled by default since at
least 2007 and
https://github.com/krb5/krb5/commit/4c17f25c0f106ec8e3aad2cee4e7a24f66b5a65d

Enable DES, MD4 and RC4 in openssl to fix build failure raised since
commit a83d41867c8d69a77d5cd0a665aa216af5340359

Fixes:
 - http://autobuild.buildroot.org/results/d73b477bd2064aee076f9debfd8d3346c63ba657

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[yann.morin.1998@free.fr: squash the two commits together]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/libkrb5/Config.in
package/libkrb5/libkrb5.mk

index 2e24c87229619132a5b2fa117cf26bffc738a8bd..3357d4ad04f0a8c1fe97b39fac8fa7c2eef2aebf 100644 (file)
@@ -3,6 +3,9 @@ config BR2_PACKAGE_LIBKRB5
        # needs fork()
        depends on BR2_USE_MMU
        depends on !BR2_STATIC_LIBS
+       select BR2_PACKAGE_LIBOPENSSL_ENABLE_DES if BR2_PACKAGE_LIBOPENSSL
+       select BR2_PACKAGE_LIBOPENSSL_ENABLE_MD4 if BR2_PACKAGE_LIBOPENSSL
+       select BR2_PACKAGE_LIBOPENSSL_ENABLE_RC4 if BR2_PACKAGE_LIBOPENSSL
        help
          Kerberos is a system for authenticating users and services
          on a network. Kerberos is a trusted third-party service.
index e4f3fa4186056f063f70f102e11587e3ad1e25ff..794cedd33cee7a2cb448408c9786be75764199e7 100644 (file)
@@ -41,6 +41,21 @@ else
 LIBKRB5_CONF_OPTS += --without-ldap
 endif
 
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+LIBKRB5_CONF_OPTS += \
+       --enable-pkinit \
+       --with-crypto-impl=openssl \
+       --with-spake-openssl \
+       --with-tls-impl=openssl
+LIBKRB5_DEPENDENCIES += openssl
+else
+LIBKRB5_CONF_OPTS += \
+       --disable-pkinit \
+       --with-crypto-impl=builtin \
+       --without-spake-openssl \
+       --without-tls-impl
+endif
+
 ifeq ($(BR2_PACKAGE_LIBEDIT),y)
 LIBKRB5_CONF_OPTS += --with-libedit
 LIBKRB5_DEPENDENCIES += host-pkgconf libedit