package/tvheadend: Fix inclusion of DVB frequency tables in bundled build
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 14 Dec 2014 09:53:29 +0000 (10:53 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 14 Dec 2014 20:40:23 +0000 (21:40 +0100)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tvheadend/tvheadend.mk

index e0ce160a12e1fceeab8ac546d6492d452d99b21b..9c93807a7d45b8fab7ab1e2736334107088f94b9 100644 (file)
@@ -50,14 +50,20 @@ define TVHEADEND_CONFIGURE_CMDS
                        --arch="$(ARCH)"                        \
                        --cpu="$(BR2_GCC_TARGET_CPU)"           \
                        --python="$(HOST_DIR)/usr/bin/python"   \
-                       --disable-dvbscan                       \
+                       --enable-dvbscan                        \
                        --enable-bundle                         \
                        --disable-libffmpeg_static              \
                        $(TVHEADEND_CONF_OPTS)                  \
        )
 endef
 
+# The tvheadend build system expects the transponder data to be present inside
+# its source tree. To prevent a downloaded initiated by the build system just
+# copy the data files in the right place and add the corresponding stamp file.
 define TVHEADEND_BUILD_CMDS
+       $(INSTALL) -d $(@D)/data/dvb-scan
+       cp -r $(TARGET_DIR)/usr/share/dvb/* $(@D)/data/dvb-scan/
+       touch $(@D)/data/dvb-scan/.stamp
        $(MAKE) -C $(@D)
 endef