package/python-iptables: new package
authorMatt Weber <matthew.weber@rockwellcollins.com>
Fri, 31 May 2019 17:16:50 +0000 (12:16 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 20 Jun 2019 20:01:56 +0000 (22:01 +0200)
This package provides Python bindings for iptables.

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
[Thomas: add license file]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-iptables/Config.in [new file with mode: 0644]
package/python-iptables/python-iptables.hash [new file with mode: 0644]
package/python-iptables/python-iptables.mk [new file with mode: 0644]

index 10e97ed53c0cdfcf793a082a65846de699e5c06b..b416cd45e89dcd97a1f4c6b43cb995743e10fe59 100644 (file)
@@ -1527,6 +1527,7 @@ F:        package/protobuf-c/
 F:     package/protobuf/
 F:     package/python-colorama/
 F:     package/python-flask-cors/
+F:     package/python-iptables/
 F:     package/python-ipy/
 F:     package/python-posix-ipc/
 F:     package/python-pypcap/
index 91301408689141ceb5b072abf65a28d268e22d42..07edde8d428c6950f2925ba5493fe6ad052bfcc9 100644 (file)
@@ -914,6 +914,7 @@ menu "External python modules"
        source "package/python-iowait/Config.in"
        source "package/python-ipaddr/Config.in"
        source "package/python-ipaddress/Config.in"
+       source "package/python-iptables/Config.in"
        source "package/python-ipy/Config.in"
        source "package/python-ipython/Config.in"
        source "package/python-ipython-genutils/Config.in"
diff --git a/package/python-iptables/Config.in b/package/python-iptables/Config.in
new file mode 100644 (file)
index 0000000..e553599
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_IPTABLES
+       bool "python-iptables"
+       select BR2_PACKAGE_IPTABLES # runtime dependency
+       help
+         Python bindings for iptables.
+
+         https://github.com/ldx/python-iptables
diff --git a/package/python-iptables/python-iptables.hash b/package/python-iptables/python-iptables.hash
new file mode 100644 (file)
index 0000000..3c83a15
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/python-iptables/json
+md5    3761a77c28ca0adc69f4e0e11af2f321  python-iptables-0.13.0.tar.gz
+sha256 53b09257467681d7ea547cd3140eccd8c70effb3748af4b56ffed2f6011189e7  python-iptables-0.13.0.tar.gz
+# Locally calculated
+sha256  b827789c74144d9bb92595ed3bc568aef767a7e8d930fba61c2cdd9f6ec27599  NOTICE
diff --git a/package/python-iptables/python-iptables.mk b/package/python-iptables/python-iptables.mk
new file mode 100644 (file)
index 0000000..4aed474
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-iptables
+#
+################################################################################
+
+PYTHON_IPTABLES_VERSION = 0.13.0
+PYTHON_IPTABLES_SITE = https://files.pythonhosted.org/packages/6e/3a/866f5b1bccc6a4d94811f84304d700da14518ff55b80e08ff2241b3221bf
+PYTHON_IPTABLES_SETUP_TYPE = setuptools
+PYTHON_IPTABLES_LICENSE = Apache-2.0
+PYTHON_IPTABLES_LICENSE_FILES = NOTICE
+
+$(eval $(python-package))