install hostutils (i.e. 'ldd' and 'ldconfig') into $STAGING_DIR
authorEric Andersen <andersen@codepoet.org>
Thu, 22 Mar 2007 16:23:43 +0000 (16:23 -0000)
committerEric Andersen <andersen@codepoet.org>
Thu, 22 Mar 2007 16:23:43 +0000 (16:23 -0000)
toolchain/uClibc/uclibc.mk

index 048f07f47a4a86dcff85fd946968a9e747209658..0e0716114ee70c7201108a7e602c1006d5c637e2 100644 (file)
@@ -285,6 +285,12 @@ $(STAGING_DIR)/lib/libc.a: $(UCLIBC_DIR)/lib/libc.a
                PREFIX=$(STAGING_DIR) \
                HOSTCC="$(HOSTCC)" \
                hostutils
+       install -c $(UCLIBC_DIR)/utils/ldd.host $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/ldd
+       (cd $(STAGING_DIR)/bin; ln -s ../$(REAL_GNU_TARGET_NAME)/bin/ldd $(GNU_TARGET_NAME)-ldd)
+       (cd $(STAGING_DIR)/bin; ln -s ../$(REAL_GNU_TARGET_NAME)/bin/ldd $(REAL_GNU_TARGET_NAME)-ldd)
+       install -c $(UCLIBC_DIR)/utils/ldconfig.host $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/bin/ldconfig
+       (cd $(STAGING_DIR)/bin; ln -s ../$(REAL_GNU_TARGET_NAME)/bin/ldconfig $(GNU_TARGET_NAME)-ldconfig)
+       (cd $(STAGING_DIR)/bin; ln -s ../$(REAL_GNU_TARGET_NAME)/bin/ldconfig $(REAL_GNU_TARGET_NAME)-ldconfig)
        touch -c $(STAGING_DIR)/lib/libc.a
 
 ifneq ($(TARGET_DIR),)