pkg-generic: reinstall target
authorDoug Kehn <rdkehn@yahoo.com>
Fri, 28 Nov 2014 15:25:04 +0000 (09:25 -0600)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 3 Feb 2015 17:05:21 +0000 (18:05 +0100)
Add a <pkg>-reinstall target, just like <pkg>-rebuild and
<pkg>-reconfigure, but that only retrigger the install step of the
package.

Signed-off-by: Doug Kehn <rdkehn@yahoo.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-generic.mk

index 38ef581a0f8de8db03590bb5813fb6f27415f61b..1b0995563164b51a2cf0796854d22b467d8d21b6 100644 (file)
@@ -577,16 +577,20 @@ $(1)-graph-depends: graph-depends-requirements
 
 $(1)-dirclean:         $$($(2)_TARGET_DIRCLEAN)
 
-$(1)-clean-for-rebuild:
+$(1)-clean-for-reinstall:
 ifneq ($$($(2)_OVERRIDE_SRCDIR),)
                        rm -f $$($(2)_TARGET_RSYNC)
 endif
-                       rm -f $$($(2)_TARGET_BUILD)
                        rm -f $$($(2)_TARGET_INSTALL_STAGING)
                        rm -f $$($(2)_TARGET_INSTALL_TARGET)
                        rm -f $$($(2)_TARGET_INSTALL_IMAGES)
                        rm -f $$($(2)_TARGET_INSTALL_HOST)
 
+$(1)-reinstall:                $(1)-clean-for-reinstall $(1)
+
+$(1)-clean-for-rebuild: $(1)-clean-for-reinstall
+                       rm -f $$($(2)_TARGET_BUILD)
+
 $(1)-rebuild:          $(1)-clean-for-rebuild $(1)
 
 $(1)-clean-for-reconfigure: $(1)-clean-for-rebuild